Skip to content

← Actionable
High, CVSS 8.5

Apache Pulsar: Improper Input Validation in Pulsar Function Worker allows Remote Code Execution

CVE-2024-27135GHSA-xp2r-g8qq-44hh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.pulsar:pulsar-functions-worker 3.2.1, 3.1.3, 3.0.3, 2.11.4, 2.10.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-xp2r-g8qq-44hh lists affected ranges: Maven org.apache.pulsar:pulsar-functions-worker >=2.4.0 =2.11.0 =3.0.0 =3.1.0 =3.2.0 <3.2.1

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.5 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2024-27135: 5.98% estimated exploitation activity in the next 30 days; percentile 93.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Improper input validation in the Pulsar Function Worker allows a malicious authenticated user to execute arbitrary Java code on the Pulsar Function worker, outside of the sandboxes designated for running user-provided functions. This vulnerability also applies to the Pulsar Broker when it is configured with "functionsWorkerEnabled=true". This issue affects Apache Pulsar versions from 2.4.0 to 2.10.5, from 2.11.0 to 2.11.3, from 3.0.0 to 3.0.2, from 3.1.0 to 3.1.2, and 3.2.0. 2.10 Pulsar Function Worker users should upgrade to at least 2.10.6. 2.11 Pulsar Function Worker users should upgrade to at least 2.11.4. 3.0 Pulsar Function Worker users should upgrade to at least 3.0.3. 3.1 Pulsar Function Worker users should upgrade to at least 3.1.3. 3.2 Pulsar Function Worker users should upgrade to at least 3.2.1. Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-xp2r-g8qq-44hh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-27135

Advisory: Apache Pulsar: Improper Input Validation in Pulsar Function Worker allows Remote Code Execution
IDs: CVE-2024-27135, GHSA-xp2r-g8qq-44hh
Record: https://patchnext.com/advisories/cve-2024-27135 (revision 1, source checked 26 Oct 2026, 16:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.pulsar:pulsar-functions-worker 3.2.1, 3.1.3, 3.0.3, 2.11.4, 2.10.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.pulsar:pulsar-functions-worker: affected >= 2.4.0, <= 2.10.5; >= 2.11.0, <= 2.11.3; >= 3.0.0, <= 3.0.2; >= 3.1.0, <= 3.1.2; >= 3.2.0, < 3.2.1; fixed in 3.2.1, 2.11.4, 3.1.3, 3.0.3, 2.10.6

## Suggested inspection (read-only)
- Maven org.apache.pulsar:pulsar-functions-worker: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.pulsar:pulsar-functions-worker.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xp2r-g8qq-44hh (GitHub-reviewed advisory GHSA-xp2r-g8qq-44hh lists affected ranges: Maven org.apache.pulsar:pulsar-functions-worker >=2.4.0 =2.11.0 =3.0.0 =3.1.0 =3.2.0 <3.2.1)

Commands are suggestions: review each one before running it.

Loading voting…