Skip to content

← Actionable
High, CVSS 7.3amended

MLflow's excessive directory permissions allow local privilege escalation

CVE-2024-27134GHSA-qpgc-w4mg-6v92

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mlflow 2.16.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI mlflow

    Affected
    < 2.16.0
    Fixed in
    2.16.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.3 · CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-27134: 0.12% estimated exploitation activity in the next 30 days; percentile 1.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Excessive directory permissions in MLflow leads to local privilege escalation when using sparkudf. This behavior can be exploited by a local attacker to gain elevated permissions by using a ToCToU attack. The issue is only relevant when the sparkudf() MLflow API is called.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-qpgc-w4mg-6v92

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-qpgc-w4mg-6v92

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-27134

Advisory: MLflow's excessive directory permissions allow local privilege escalation
IDs: CVE-2024-27134, GHSA-qpgc-w4mg-6v92
Record: https://patchnext.com/advisories/cve-2024-27134 (revision 3, source checked 26 Oct 2026, 13:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mlflow 2.16.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI mlflow: affected < 2.16.0; fixed in 2.16.0

## Suggested inspection (read-only)
- `python -m pip show mlflow`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mlflow.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-qpgc-w4mg-6v92 (OSV record GHSA-qpgc-w4mg-6v92 lists affected ranges: PyPI mlflow >=0 <2.16.0 (fixed))
- Verified: https://github.com/advisories/GHSA-qpgc-w4mg-6v92 (GitHub-reviewed advisory GHSA-qpgc-w4mg-6v92 lists affected ranges: PyPI mlflow >=0 <2.16.0)

Commands are suggestions: review each one before running it.

Loading voting…