Skip to content

← Actionable
Critical, CVSS 9.9

Pterodactyl Wings vulnerable to improper isolation of server file access

CVE-2024-27102GHSA-494h-9924-xww9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/pterodactyl/wings 1.11.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2024-27102: 0.55% estimated exploitation activity in the next 30 days; percentile 45.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact This vulnerability impacts anyone running the affected versions of Wings. The vulnerability can potentially be used to access files and directories on the host system. The full scope of impact is exactly unknown, but reading files outside of a server's base directory (sandbox root) is possible. In order to use this exploit, an attacker must have an existing "server" allocated and controlled by Wings. Details on the exploitation of this vulnerability are embargoed until March 27th, 2024 at 18:00 UTC. Resolution In order to mitigate this vulnerability, a full rewrite of the entire server filesystem was necessary. Because of this, the size of the patch is massive, however effort was made to reduce the amount of breaking changes. While tests were written to ensure security and functionality, there may be some semantic differences of certain operations, such as different errors being returned for example. If you notice any major semantic differences, please open an issue on our…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-494h-9924-xww9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-27102

Advisory: Pterodactyl Wings vulnerable to improper isolation of server file access
IDs: CVE-2024-27102, GHSA-494h-9924-xww9
Record: https://patchnext.com/advisories/cve-2024-27102 (revision 1, source checked 26 Oct 2026, 15:03 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/pterodactyl/wings 1.11.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/pterodactyl/wings: affected < 1.11.9; fixed in 1.11.9

## Suggested inspection (read-only)
- Go github.com/pterodactyl/wings: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/pterodactyl/wings.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-494h-9924-xww9 (GitHub-reviewed advisory GHSA-494h-9924-xww9 lists affected ranges: Go github.com/pterodactyl/wings >=0 <1.11.9)

Commands are suggestions: review each one before running it.

Loading voting…