Skip to content

← Actionable
High, CVSS 7.3

Integer overflow in chunking helper causes dispatching to miss elements or panic

CVE-2024-27101GHSA-h3m7-rqc4-7h9p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/authzed/spicedb 1.29.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.3 · CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:N/I:H/A:H
EPSS
  • CVE-2024-27101: 0.46% estimated exploitation activity in the next 30 days; percentile 39.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Any SpiceDB cluster with any schema where a resource being checked has more than 65535 relationships for the same resource and subject type is affected by this problem. The issue may also lead to a panic rendering the server unavailable The following API methods are affected: - CheckPermission - BulkCheckPermission - LookupSubjects Impact Permission checks that are expected to be allowed are instead denied, and lookup subjects will return fewer subjects than expected. Workarounds There is no workaround other than making sure that the SpiceDB cluster does not have very wide relations, with the maximum value being the maximum value of an 16-bit unsigned integer Remediations - AuthZed Dedicated customers: No action. AuthZed has upgraded all deployments. - AuthZed Serverless customers: No Action. AuthZed has upgraded all deployments. - AuthZed Enterprise customers: Upgrade to v1.29.2-hotfix-enterprise.v1.hotfix.v1 - Open Source users: Upgrade to v1.29.2

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-h3m7-rqc4-7h9p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-27101

Advisory: Integer overflow in chunking helper causes dispatching to miss elements or panic
IDs: CVE-2024-27101, GHSA-h3m7-rqc4-7h9p
Record: https://patchnext.com/advisories/cve-2024-27101 (revision 1, source checked 26 Oct 2026, 15:18 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/authzed/spicedb 1.29.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/authzed/spicedb: affected < 1.29.2; fixed in 1.29.2

## Suggested inspection (read-only)
- Go github.com/authzed/spicedb: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/authzed/spicedb.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-h3m7-rqc4-7h9p (GitHub-reviewed advisory GHSA-h3m7-rqc4-7h9p lists affected ranges: Go github.com/authzed/spicedb >=0 <1.29.2)

Commands are suggestions: review each one before running it.

Loading voting…