Skip to content

← Actionable
Medium, CVSS 6.5amended

OpenZeppelin Contracts base64 encoding may read from potentially dirty memory

CVE-2024-27094GHSA-9vx6-7xxf-x967

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@openzeppelin/contracts 5.0.2, 4.9.6; @openzeppelin/contracts-upgradeable 5.0.2, 4.9.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:H
EPSS
  • CVE-2024-27094: 0.76% estimated exploitation activity in the next 30 days; percentile 55.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The Base64.encode function encodes a bytes input by iterating over it in chunks of 3 bytes. When this input is not a multiple of 3, the last iteration may read parts of the memory that are beyond the input buffer. Although the encode function pads the output for these cases, up to 4 bits of data are kept between the encoding and padding, corrupting the output if these bits were dirty (i.e. memory after the input is not 0). These conditions are more frequent in the following scenarios: - A bytes memory struct is allocated just after the input and the first bytes of it are non-zero. - The memory pointer is set to a non-empty memory location before allocating the input. Developers should evaluate whether the extra bits can be maliciously manipulated by an attacker. Patches Upgrade to 5.0.2 or 4.9.6. References This issue was reported by the Independent Security Researcher Riley Holterhus through Immunefi (@rileyholterhus on X)

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-9vx6-7xxf-x967

  2. Revision 1 · created ·

    Published from osv record GHSA-9vx6-7xxf-x967

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-27094

Advisory: OpenZeppelin Contracts base64 encoding may read from potentially dirty memory
IDs: CVE-2024-27094, GHSA-9vx6-7xxf-x967
Record: https://patchnext.com/advisories/cve-2024-27094 (revision 2, source checked 26 Oct 2026, 12:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @openzeppelin/contracts 5.0.2, 4.9.6; @openzeppelin/contracts-upgradeable 5.0.2, 4.9.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @openzeppelin/contracts: affected >= 4.5.0, < 4.9.6; >= 5.0.0-rc.0, < 5.0.2; fixed in 4.9.6, 5.0.2
- npm @openzeppelin/contracts-upgradeable: affected >= 5.0.0-rc.0, < 5.0.2; >= 4.5.0, < 4.9.6; fixed in 4.9.6, 5.0.2

## Suggested inspection (read-only)
- `npm ls @openzeppelin/contracts --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @openzeppelin/contracts-upgradeable --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @openzeppelin/contracts, @openzeppelin/contracts-upgradeable.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9vx6-7xxf-x967 (OSV record GHSA-9vx6-7xxf-x967 lists affected ranges: npm @openzeppelin/contracts >=4.5.0 =5.0.0-rc.0 =5.0.0-rc.0 =4.5.0 <4.9.6 (fixed))
- Verified: https://github.com/advisories/GHSA-9vx6-7xxf-x967 (GitHub-reviewed advisory GHSA-9vx6-7xxf-x967 lists affected ranges: npm @openzeppelin/contracts >=4.5.0 =5.0.0-rc.0 =5.0.0-rc.0 =4.5.0 <4.9.6)

Commands are suggestions: review each one before running it.

Loading voting…