Skip to content

← Actionable
Medium, CVSS 6.1amended

GeoNode: Stored XSS to full account takeover

CVE-2024-27091GHSA-rwcv-whm8-fmxm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (geonode 4.2.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI geonode

    Affected
    >= 3.2.1, < 4.2.3
    Fixed in
    4.2.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2024-27091: 0.38% estimated exploitation activity in the next 30 days; percentile 32.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An issue exists within GEONODE where the current rich text editor is vulnerable to Stored XSS. The applications cookies are set securely, but it is possible to retrieve a victims CSRF token and issue a request to change another user's email address to perform a full account takeover. Due to the script element not impacting the CORS policy, requests will succeed.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-rwcv-whm8-fmxm

  2. Revision 1 · created ·

    Published from osv record GHSA-rwcv-whm8-fmxm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-27091

Advisory: GeoNode: Stored XSS to full account takeover
IDs: CVE-2024-27091, GHSA-rwcv-whm8-fmxm
Record: https://patchnext.com/advisories/cve-2024-27091 (revision 2, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: geonode 4.2.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI geonode: affected >= 3.2.1, < 4.2.3; fixed in 4.2.3

## Suggested inspection (read-only)
- `python -m pip show geonode`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on geonode.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rwcv-whm8-fmxm (OSV record GHSA-rwcv-whm8-fmxm lists affected ranges: PyPI geonode >=3.2.1 <4.2.3 (fixed))
- Verified: https://github.com/advisories/GHSA-rwcv-whm8-fmxm (GitHub-reviewed advisory GHSA-rwcv-whm8-fmxm lists affected ranges: PyPI geonode >=3.2.1 <4.2.3)

Commands are suggestions: review each one before running it.

Loading voting…