Flask-AppBuilder's OAuth login page subject to Cross Site Scripting (XSS)
CVE-2024-27083GHSA-fqxj-46wg-9v84
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (flask-appbuilder 4.2.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI flask-appbuilder
- Affected
- >= 4.1.4, < 4.2.1
- Fixed in
- 4.2.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-fqxj-46wg-9v84 lists affected ranges: PyPI flask-appbuilder >=4.1.4 <4.2.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fqxj-46wg-9v84 lists affected ranges: PyPI flask-appbuilder >=4.1.4 <4.2.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N
- EPSS
- CVE-2024-27083: 0.57% estimated exploitation activity in the next 30 days; percentile 47.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A Cross-Site Scripting (XSS) vulnerability has been discovered on the OAuth login page. An attacker could trick a user to follow a specially crafted URL to the OAuth login page. This URL could inject and execute malicious javascript code that would get executed on the user's browser. Impacted versions: Flask-AppBuilder version 4.1.4 up to and including 4.2.0 Patches This issue was introduced on 4.1.4 and patched on 4.2.1, user's should upgrade to 4.2.1 or newer versions.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-fqxj-46wg-9v84
- Revision 1 · created ·
Published from osv record GHSA-fqxj-46wg-9v84
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-27083 Advisory: Flask-AppBuilder's OAuth login page subject to Cross Site Scripting (XSS) IDs: CVE-2024-27083, GHSA-fqxj-46wg-9v84 Record: https://patchnext.com/advisories/cve-2024-27083 (revision 2, source checked 26 Oct 2026, 13:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: flask-appbuilder 4.2.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI flask-appbuilder: affected >= 4.1.4, < 4.2.1; fixed in 4.2.1 ## Suggested inspection (read-only) - `python -m pip show flask-appbuilder`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on flask-appbuilder. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-fqxj-46wg-9v84 (OSV record GHSA-fqxj-46wg-9v84 lists affected ranges: PyPI flask-appbuilder >=4.1.4 <4.2.1 (fixed)) - Verified: https://github.com/advisories/GHSA-fqxj-46wg-9v84 (GitHub-reviewed advisory GHSA-fqxj-46wg-9v84 lists affected ranges: PyPI flask-appbuilder >=4.1.4 <4.2.1) Commands are suggestions: review each one before running it.
Loading voting…