AMPHP Denial of Service via HTTP/2 CONTINUATION Frames
CVE-2024-2653GHSA-qjfw-cvjf-f4fm
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist amphp/http-client
- Affected
- >= 4.0.0-rc10, <= 4.0.0
- Fixed in
- no fixed version recorded
Packagist amphp/http
- Affected
- >= 2.0.0, <= 2.1.0<= 1.7.2
- Fixed in
- 1.7.3, 2.1.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qjfw-cvjf-f4fm lists affected ranges: Packagist amphp/http >=2.0.0 =0 =4.0.0-rc10 <=4.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H
- EPSS
- CVE-2024-2653: 80.26% estimated exploitation activity in the next 30 days; percentile 99.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
amphp/http will collect HTTP/2 CONTINUATION frames in an unbounded buffer and will not check the header size limit until it has received the ENDHEADERS flag, resulting in an OOM crash. amphp/http-client and amphp/http-server are indirectly affected if they're used with an unpatched version of amphp/http. Early versions of amphp/http-client with HTTP/2 support (v4.0.0-rc10 to 4.0.0) are also directly affected. Acknowledgements Thank you to Bartek Nowotarski for reporting the vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qjfw-cvjf-f4fm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-2653 Advisory: AMPHP Denial of Service via HTTP/2 CONTINUATION Frames IDs: CVE-2024-2653, GHSA-qjfw-cvjf-f4fm Record: https://patchnext.com/advisories/cve-2024-2653 (revision 1, source checked 26 Oct 2026, 14:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: amphp/http 2.1.1, 1.7.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist amphp/http-client: affected >= 4.0.0-rc10, <= 4.0.0 - Packagist amphp/http: affected >= 2.0.0, <= 2.1.0; <= 1.7.2; fixed in 1.7.3, 2.1.1 ## Suggested inspection (read-only) - Packagist amphp/http-client: check the installed version with your package manager. - Packagist amphp/http: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on amphp/http-client, amphp/http. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qjfw-cvjf-f4fm (GitHub-reviewed advisory GHSA-qjfw-cvjf-f4fm lists affected ranges: Packagist amphp/http >=2.0.0 =0 =4.0.0-rc10 <=4.0.0) Commands are suggestions: review each one before running it.
Loading voting…