Kirby vulnerable to self cross-site scripting (self-XSS) in the URL field
CVE-2024-26481GHSA-57f2-8p89-66x6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (getkirby/cms 4.1.1, 3.10.0.1, 3.9.8.1, 3.8.4.3, 3.7.5.4, 3.6.6.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist getkirby/cms
- Affected
- <= 3.6.6.4>= 3.7.0, <= 3.7.5.3>= 3.8.0, <= 3.8.4.2>= 3.9.0, <= 3.9.8>= 3.10.0, <= 3.10.0>= 4.0.0, <= 4.1.0
- Fixed in
- 3.6.6.5, 3.9.8.1, 3.10.0.1, 4.1.1, 3.7.5.4, 3.8.4.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-57f2-8p89-66x6 lists affected ranges: Packagist getkirby/cms >=0 =3.7.0 =3.8.0 =3.9.0 =3.10.0 =4.0.0 <=4.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.2 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N
- EPSS
- CVE-2024-26481: 0.40% estimated exploitation activity in the next 30 days; percentile 34.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
TL;DR This vulnerability affects Kirby sites that use the URL field in any blueprint. A successful attack commonly requires knowledge of the content structure by the attacker as well as social engineering of a user with access to the Panel. The attack cannot be automated. The vulnerability is also limited to self-XSS and cannot directly affect other users or visitors of the site. ---- Introduction Cross-site scripting (XSS) is a type of vulnerability that allows to execute any kind of JavaScript code inside the Panel session of the same or other users. In the Panel, a harmful script can for example trigger requests to Kirby's API with the permissions of the victim. Self cross-site scripting (self-XSS, also called reflected XSS) typically involves a user inadvertently executing malicious code within their own context, often through social engineering techniques. This can occur when a user is tricked into pasting and executing malicious JavaScript code into the browser's developer…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-57f2-8p89-66x6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-26481 Advisory: Kirby vulnerable to self cross-site scripting (self-XSS) in the URL field IDs: CVE-2024-26481, GHSA-57f2-8p89-66x6 Record: https://patchnext.com/advisories/cve-2024-26481 (revision 1, source checked 26 Oct 2026, 14:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: getkirby/cms 4.1.1, 3.10.0.1, 3.9.8.1, 3.8.4.3, 3.7.5.4, 3.6.6.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist getkirby/cms: affected <= 3.6.6.4; >= 3.7.0, <= 3.7.5.3; >= 3.8.0, <= 3.8.4.2; >= 3.9.0, <= 3.9.8; >= 3.10.0, <= 3.10.0; >= 4.0.0, <= 4.1.0; fixed in 3.6.6.5, 3.9.8.1, 3.10.0.1, 4.1.1, 3.7.5.4, 3.8.4.3 ## Suggested inspection (read-only) - Packagist getkirby/cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on getkirby/cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-57f2-8p89-66x6 (GitHub-reviewed advisory GHSA-57f2-8p89-66x6 lists affected ranges: Packagist getkirby/cms >=0 =3.7.0 =3.8.0 =3.9.0 =3.10.0 =4.0.0 <=4.1.0) Commands are suggestions: review each one before running it.
Loading voting…