Skip to content

← Actionable
High, CVSS 8.2amended

Potentially untrusted input is rendered as HTML in final output

CVE-2024-26151GHSA-578p-fxmm-6229

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mjml 0.11.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI mjml

    Affected
    >= 0.10.0, <= 0.10.0
    Fixed in
    0.11.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.2 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:H/A:L
EPSS
  • CVE-2024-26151: 0.62% estimated exploitation activity in the next 30 days; percentile 49.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact All users of mjml-python who insert untrusted data into mjml templates unless that data is checked in a very strict manner. User input like &lt;script&gt; would be rendered as <script in the final HTML output. The attacker must be able to control some data which is later injected in an mjml template which is then send out as email to other users. The attacker could control contents of email messages sent through the platform. Patches The problem has been fixed in version 0.11.0 of this library. Versions before 0.10.0 are not affected by this security issue which was added as part of commit 84c495da20a91640a1ca551ace17df7f3be644aa. Workarounds - Ensure that potentially untrusted user input does not contain any sequences which could be rendered as HTML. References - Initial issue report by @sh-at-cs in #52

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-578p-fxmm-6229

  2. Revision 1 · created ·

    Published from osv record GHSA-578p-fxmm-6229

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-26151

Advisory: Potentially untrusted input is rendered as HTML in final output
IDs: CVE-2024-26151, GHSA-578p-fxmm-6229
Record: https://patchnext.com/advisories/cve-2024-26151 (revision 2, source checked 26 Oct 2026, 13:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mjml 0.11.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI mjml: affected >= 0.10.0, <= 0.10.0; fixed in 0.11.0

## Suggested inspection (read-only)
- `python -m pip show mjml`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mjml.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-578p-fxmm-6229 (OSV record GHSA-578p-fxmm-6229 lists affected ranges: PyPI mjml >=0.10.0 <0.11.0 (fixed))
- Verified: https://github.com/advisories/GHSA-578p-fxmm-6229 (GitHub-reviewed advisory GHSA-578p-fxmm-6229 lists affected ranges: PyPI mjml >=0.10.0 <=0.10.0)

Commands are suggestions: review each one before running it.

Loading voting…