Skip to content

← Actionable
Low, CVSS 3.7amended

Vyper's _abi_decode vulnerable to Memory Overflow

CVE-2024-26149GHSA-9p8r-4xp4-gw5w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vyper 0.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI vyper

    Affected
    < 0.4.0
    Fixed in
    0.4.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2024-26149: 0.55% estimated exploitation activity in the next 30 days; percentile 45.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary If an excessively large value is specified as the starting index for an array in abidecode, it can cause the read position to overflow. This results in the decoding of values outside the intended array bounds, potentially leading to bugs in contracts that use arrays within abidecode. The advisory has been assigned low severity, because it is only observable if there is a memory write between two invocations of abidecode on the same input. Proof of Concept Sending the following calldata results in Pwn being emitted. Patches Patched in https://github.com/vyperlang/vyper/pull/3925, https://github.com/vyperlang/vyper/pull/4091, https://github.com/vyperlang/vyper/pull/4144, https://github.com/vyperlang/vyper/pull/4060.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-9p8r-4xp4-gw5w

  2. Revision 1 · created ·

    Published from osv record GHSA-9p8r-4xp4-gw5w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-26149

Advisory: Vyper's `_abi_decode` vulnerable to Memory Overflow
IDs: CVE-2024-26149, GHSA-9p8r-4xp4-gw5w
Record: https://patchnext.com/advisories/cve-2024-26149 (revision 2, source checked 26 Oct 2026, 13:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vyper 0.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI vyper: affected < 0.4.0; fixed in 0.4.0

## Suggested inspection (read-only)
- `python -m pip show vyper`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vyper.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9p8r-4xp4-gw5w (OSV record GHSA-9p8r-4xp4-gw5w lists affected ranges: PyPI vyper >=0 <0.4.0 (fixed))
- Verified: https://github.com/advisories/GHSA-9p8r-4xp4-gw5w (GitHub-reviewed advisory GHSA-9p8r-4xp4-gw5w lists affected ranges: PyPI vyper >=0 <0.4.0)

Commands are suggestions: review each one before running it.

Loading voting…