Skip to content

← Actionable
Medium, CVSS 6.1

Rails has possible XSS Vulnerability in Action Controller

CVE-2024-26143GHSA-9822-6m93-xqf4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (actionpack 7.1.3.1, 7.0.8.1; rails 7.1.3.1, 7.0.8.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems actionpack

    Affected
    >= 7.0.0, < 7.0.8.1>= 7.1.0, < 7.1.3.1
    Fixed in
    7.0.8.1, 7.1.3.1
  • RubyGems rails

    Affected
    >= 7.0.0, < 7.0.8.1>= 7.1.0, < 7.1.3.1
    Fixed in
    7.0.8.1, 7.1.3.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2024-26143: 1.03% estimated exploitation activity in the next 30 days; percentile 63.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Possible XSS Vulnerability in Action Controller There is a possible XSS vulnerability when using the translation helpers (translate, t, etc) in Action Controller. This vulnerability has been assigned the CVE identifier CVE-2024-26143. Versions Affected: = 7.0.0. Not affected: < 7.0.0 Fixed Versions: 7.1.3.1, 7.0.8.1 Impact ------ Applications using translation methods like translate, or t on a controller, with a key ending in "html", a :default key which contains untrusted user input, and the resulting string is used in a view, may be susceptible to an XSS vulnerability. For example, impacted code will look something like this: To reiterate the pre-conditions, applications must: Use a translation function from a controller (i.e. not I18n.t, or t from a view) Use a key that ends in html Use a default value where the default value is untrusted and unescaped input Send the text to the victim (whether that's part of a template, or a render call) All users running an affected release…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9822-6m93-xqf4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-26143

Advisory: Rails has possible XSS Vulnerability in Action Controller
IDs: CVE-2024-26143, GHSA-9822-6m93-xqf4
Record: https://patchnext.com/advisories/cve-2024-26143 (revision 1, source checked 26 Oct 2026, 15:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: actionpack 7.1.3.1, 7.0.8.1; rails 7.1.3.1, 7.0.8.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems actionpack: affected >= 7.0.0, < 7.0.8.1; >= 7.1.0, < 7.1.3.1; fixed in 7.0.8.1, 7.1.3.1
- RubyGems rails: affected >= 7.0.0, < 7.0.8.1; >= 7.1.0, < 7.1.3.1; fixed in 7.0.8.1, 7.1.3.1

## Suggested inspection (read-only)
- RubyGems actionpack: check the installed version with your package manager.
- RubyGems rails: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on actionpack, rails.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9822-6m93-xqf4 (GitHub-reviewed advisory GHSA-9822-6m93-xqf4 lists affected ranges: RubyGems actionpack >=7.0.0 =7.1.0 =7.0.0 =7.1.0 <7.1.3.1)

Commands are suggestions: review each one before running it.

Loading voting…