Rack has possible DoS Vulnerability with Range Header
CVE-2024-26141GHSA-xj5v-6v4g-jfw6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (rack 3.0.9.1, 2.2.8.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems rack
- Affected
- >= 3.0.0, < 3.0.9.1>= 1.3.0, < 2.2.8.1
- Fixed in
- 2.2.8.1, 3.0.9.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xj5v-6v4g-jfw6 lists affected ranges: RubyGems rack >=3.0.0 =1.3.0 <2.2.8.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2024-26141: 1.61% estimated exploitation activity in the next 30 days; percentile 76.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Possible DoS Vulnerability with Range Header in Rack There is a possible DoS vulnerability relating to the Range request header in Rack. This vulnerability has been assigned the CVE identifier CVE-2024-26141. Versions Affected: = 1.3.0. Not affected: < 1.3.0 Fixed Versions: 3.0.9.1, 2.2.8.1 Impact ------ Carefully crafted Range headers can cause a server to respond with an unexpectedly large response. Responding with such large responses could lead to a denial of service issue. Vulnerable applications will use the Rack::File middleware or the Rack::Utils.byteranges methods (this includes Rails applications). Releases -------- The fixed releases are available at the normal locations. Workarounds ----------- There are no feasible workarounds for this issue. Patches ------- To aid users who aren't able to upgrade immediately we have provided patches for the two supported release series. They are in git-am format and consist of a single changeset. 3-0-range.patch - Patch for 3.0 series…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-xj5v-6v4g-jfw6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-26141 Advisory: Rack has possible DoS Vulnerability with Range Header IDs: CVE-2024-26141, GHSA-xj5v-6v4g-jfw6 Record: https://patchnext.com/advisories/cve-2024-26141 (revision 1, source checked 26 Oct 2026, 15:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: rack 3.0.9.1, 2.2.8.1. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems rack: affected >= 3.0.0, < 3.0.9.1; >= 1.3.0, < 2.2.8.1; fixed in 2.2.8.1, 3.0.9.1 ## Suggested inspection (read-only) - RubyGems rack: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on rack. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xj5v-6v4g-jfw6 (GitHub-reviewed advisory GHSA-xj5v-6v4g-jfw6 lists affected ranges: RubyGems rack >=3.0.0 =1.3.0 <2.2.8.1) Commands are suggestions: review each one before running it.
Loading voting…