cryptography NULL pointer dereference with pkcs12.serialize_key_and_certificates when called with a non-matching certificate and private key and an hmac_hash override
CVE-2024-26130GHSA-6vqw-3v5j-54x4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (cryptography 42.0.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI cryptography
- Affected
- >= 38.0.0, < 42.0.4
- Fixed in
- 42.0.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6vqw-3v5j-54x4 lists affected ranges: PyPI cryptography >=38.0.0 <42.0.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6vqw-3v5j-54x4 lists affected ranges: PyPI cryptography >=38.0.0 <42.0.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2024-26130: 0.83% estimated exploitation activity in the next 30 days; percentile 57.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
If pkcs12.serializekeyandcertificates is called with both: 1. A certificate whose public key did not match the provided private key 2. An encryptionalgorithm with hmachash set (via PrivateFormat.PKCS12.encryptionbuilder().hmachash(...) Then a NULL pointer dereference would occur, crashing the Python process. This has been resolved, and now a ValueError is properly raised. Patched in https://github.com/pyca/cryptography/pull/10423
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-6vqw-3v5j-54x4
- Revision 1 · created ·
Published from osv record GHSA-6vqw-3v5j-54x4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-26130 Advisory: cryptography NULL pointer dereference with pkcs12.serialize_key_and_certificates when called with a non-matching certificate and private key and an hmac_hash override IDs: CVE-2024-26130, GHSA-6vqw-3v5j-54x4 Record: https://patchnext.com/advisories/cve-2024-26130 (revision 2, source checked 26 Oct 2026, 13:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: cryptography 42.0.4. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI cryptography: affected >= 38.0.0, < 42.0.4; fixed in 42.0.4 ## Suggested inspection (read-only) - `python -m pip show cryptography`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on cryptography. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-6vqw-3v5j-54x4 (OSV record GHSA-6vqw-3v5j-54x4 lists affected ranges: PyPI cryptography >=38.0.0 <42.0.4 (fixed)) - Verified: https://github.com/advisories/GHSA-6vqw-3v5j-54x4 (GitHub-reviewed advisory GHSA-6vqw-3v5j-54x4 lists affected ranges: PyPI cryptography >=38.0.0 <42.0.4) Commands are suggestions: review each one before running it.
Loading voting…