Skip to content

← Actionable
High, CVSS 7.5

Uncontrolled Resource Consumption in moodle

CVE-2024-25978GHSA-487g-3m3v-hjhq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 4.3.3, 4.2.6, 4.1.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist moodle/moodle

    Affected
    >= 4.3.0, < 4.3.3>= 4.2.0, < 4.2.6< 4.1.9
    Fixed in
    4.1.9, 4.3.3, 4.2.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2024-25978: 0.94% estimated exploitation activity in the next 30 days; percentile 61.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Insufficient file size checks resulted in a denial of service risk in the file picker's unzip functionality.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-487g-3m3v-hjhq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-25978

Advisory: Uncontrolled Resource Consumption in moodle
IDs: CVE-2024-25978, GHSA-487g-3m3v-hjhq
Record: https://patchnext.com/advisories/cve-2024-25978 (revision 1, source checked 26 Oct 2026, 14:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 4.3.3, 4.2.6, 4.1.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist moodle/moodle: affected >= 4.3.0, < 4.3.3; >= 4.2.0, < 4.2.6; < 4.1.9; fixed in 4.1.9, 4.3.3, 4.2.6

## Suggested inspection (read-only)
- Packagist moodle/moodle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on moodle/moodle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-487g-3m3v-hjhq (GitHub-reviewed advisory GHSA-487g-3m3v-hjhq lists affected ranges: Packagist moodle/moodle >=4.3.0 =4.2.0 =0 <4.1.9)

Commands are suggestions: review each one before running it.

Loading voting…