ZenML Server Remote Privilege Escalation Vulnerability
CVE-2024-25723GHSA-vf7j-cmrj-pmmm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (zenml 0.46.7, 0.44.4, 0.43.1, 0.42.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI zenml
- Affected
- < 0.42.2>= 0.43.0, <= 0.43.0>= 0.45.0, < 0.46.7>= 0.44.0, < 0.44.4
- Fixed in
- 0.42.2, 0.44.4, 0.43.1, 0.46.7
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vf7j-cmrj-pmmm lists affected ranges: PyPI zenml >=0 =0.43.0 =0.45.0 =0.44.0 <0.44.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vf7j-cmrj-pmmm lists affected ranges: PyPI zenml >=0 =0.43.0 =0.45.0 =0.44.0 <0.44.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-25723: 70.78% estimated exploitation activity in the next 30 days; percentile 99.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
ZenML Server in the ZenML package before 0.46.7 for Python allows remote privilege escalation because the /api/v1/users/{usernameorid}/activate REST API endpoint allows access on the basis of a valid username along with a new password in the request body. These are also patched versions: 0.44.4, 0.43.1, and 0.42.2.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-vf7j-cmrj-pmmm
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-vf7j-cmrj-pmmm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-25723 Advisory: ZenML Server Remote Privilege Escalation Vulnerability IDs: CVE-2024-25723, GHSA-vf7j-cmrj-pmmm Record: https://patchnext.com/advisories/cve-2024-25723 (revision 3, source checked 26 Oct 2026, 13:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: zenml 0.46.7, 0.44.4, 0.43.1, 0.42.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI zenml: affected < 0.42.2; >= 0.43.0, <= 0.43.0; >= 0.45.0, < 0.46.7; >= 0.44.0, < 0.44.4; fixed in 0.42.2, 0.44.4, 0.43.1, 0.46.7 ## Suggested inspection (read-only) - `python -m pip show zenml`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on zenml. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-vf7j-cmrj-pmmm (OSV record GHSA-vf7j-cmrj-pmmm lists affected ranges: PyPI zenml >=0 =0.43.0 =0.45.0 =0.44.0 <0.44.4 (fixed)) - Verified: https://github.com/advisories/GHSA-vf7j-cmrj-pmmm (GitHub-reviewed advisory GHSA-vf7j-cmrj-pmmm lists affected ranges: PyPI zenml >=0 =0.43.0 =0.45.0 =0.44.0 <0.44.4) Commands are suggestions: review each one before running it.
Loading voting…