Skip to content

← Actionable
High, CVSS 8.1

Pimcore Host Header Injection in user invitation link

CVE-2024-25625GHSA-3qpq-6w89-f7mx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pimcore/admin-ui-classic-bundle 1.3.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:N
EPSS
  • CVE-2024-25625: 0.68% estimated exploitation activity in the next 30 days; percentile 52.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Overview A potential security vulnerability discovered in pimcore/admin-ui-classic-bundle version up to v1.3.3 . The vulnerability involves a Host Header Injection in the invitationLinkAction function of the UserController, specifically in the way $loginUrl trusts user input. Details The host header from incoming HTTP requests is used unsafely when generating URLs. An attacker can manipulate the HTTP host header in requests to the /admin/user/invitationlink endpoint, resulting in the generation of URLs with the attacker's domain. In fact, if a host header is injected in the POST request, the $loginURL parameter is constructed with this unvalidated host header. It is then used to send an invitation email to the provided user. Here is an excerpt from the affected section of UserController.php file: The $loginUrl variable is constructed using the generateCustomUrl function. If an attacker injects a malicious host header into a POST request, the resulting $loginUrl will include the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3qpq-6w89-f7mx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-25625

Advisory: Pimcore Host Header Injection in user invitation link
IDs: CVE-2024-25625, GHSA-3qpq-6w89-f7mx
Record: https://patchnext.com/advisories/cve-2024-25625 (revision 1, source checked 26 Oct 2026, 14:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pimcore/admin-ui-classic-bundle 1.3.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist pimcore/admin-ui-classic-bundle: affected < 1.3.4; fixed in 1.3.4

## Suggested inspection (read-only)
- Packagist pimcore/admin-ui-classic-bundle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pimcore/admin-ui-classic-bundle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3qpq-6w89-f7mx (GitHub-reviewed advisory GHSA-3qpq-6w89-f7mx lists affected ranges: Packagist pimcore/admin-ui-classic-bundle >=0 <1.3.4)

Commands are suggestions: review each one before running it.

Loading voting…