Skip to content

← Actionable
High, CVSS 7.3

containerd affected by a local privilege escalation via wide permissions on CRI directory

CVE-2024-25621GHSA-pwhc-rpq9-4c8w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/containerd/containerd/v2 2.2.0, 2.1.5, 2.0.7; github.com/containerd/containerd 1.7.29), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.3 · CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2024-25621: 0.17% estimated exploitation activity in the next 30 days; percentile 6.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An overly broad default permission vulnerability was found in containerd. - /var/lib/containerd was created with the permission bits 0o711, while it should be created with 0o700 - Allowed local users on the host to potentially access the metadata store and the content store - /run/containerd/io.containerd.grpc.v1.cri was created with 0o755, while it should be created with 0o700 - Allowed local users on the host to potentially access the contents of Kubernetes local volumes. The contents of volumes might include setuid binaries, which could allow a local user on the host to elevate privileges on the host. - /run/containerd/io.containerd.sandbox.controller.v1.shim was created with 0o711, while it should be created with 0o700 The directory paths may differ depending on the daemon configuration. When the temp directory path is specified in the daemon configuration, that directory was also created with 0o711, while it should be created with 0o700. Patches This bug has been fixed in…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-pwhc-rpq9-4c8w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-25621

Advisory: containerd affected by a local privilege escalation via wide permissions on CRI directory
IDs: CVE-2024-25621, GHSA-pwhc-rpq9-4c8w
Record: https://patchnext.com/advisories/cve-2024-25621 (revision 1, source checked 26 Oct 2026, 15:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/containerd/containerd/v2 2.2.0, 2.1.5, 2.0.7; github.com/containerd/containerd 1.7.29. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/containerd/containerd/v2: affected < 2.0.7; >= 2.1.0-beta.0, < 2.1.5; >= 2.2.0-beta.0, < 2.2.0; fixed in 2.2.0, 2.1.5, 2.0.7
- Go github.com/containerd/containerd: affected < 1.7.29; fixed in 1.7.29

## Suggested inspection (read-only)
- Go github.com/containerd/containerd/v2: check the installed version with your package manager.
- Go github.com/containerd/containerd: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/containerd/containerd/v2, github.com/containerd/containerd.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-pwhc-rpq9-4c8w (GitHub-reviewed advisory GHSA-pwhc-rpq9-4c8w lists affected ranges: Go github.com/containerd/containerd >=0 =0 =2.1.0-beta.0 =2.2.0-beta.0 <2.2.0)

Commands are suggestions: review each one before running it.

Loading voting…