Apache Airflow does not return the "Cache-Control" header for dynamic content
CVE-2024-25142GHSA-9xpj-62mm-24h2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-airflow 2.9.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI apache-airflow
- Affected
- < 2.9.2
- Fixed in
- 2.9.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9xpj-62mm-24h2 lists affected ranges: PyPI apache-airflow >=0 <2.9.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9xpj-62mm-24h2 lists affected ranges: PyPI apache-airflow >=0 <2.9.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2024-25142: 0.32% estimated exploitation activity in the next 30 days; percentile 25.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Use of Web Browser Cache Containing Sensitive Information vulnerability in Apache Airflow. Airflow did not return "Cache-Control" header for dynamic content, which in case of some browsers could result in potentially storing sensitive data in local cache of the browser. This issue affects Apache Airflow: before 2.9.2. Users are recommended to upgrade to version 2.9.2, which fixes the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-9xpj-62mm-24h2
- Revision 1 · created ·
Published from osv record GHSA-9xpj-62mm-24h2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-25142 Advisory: Apache Airflow does not return the "Cache-Control" header for dynamic content IDs: CVE-2024-25142, GHSA-9xpj-62mm-24h2 Record: https://patchnext.com/advisories/cve-2024-25142 (revision 2, source checked 26 Oct 2026, 13:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apache-airflow 2.9.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI apache-airflow: affected < 2.9.2; fixed in 2.9.2 ## Suggested inspection (read-only) - `python -m pip show apache-airflow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apache-airflow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9xpj-62mm-24h2 (OSV record GHSA-9xpj-62mm-24h2 lists affected ranges: PyPI apache-airflow >=0 <2.9.2 (fixed)) - Verified: https://github.com/advisories/GHSA-9xpj-62mm-24h2 (GitHub-reviewed advisory GHSA-9xpj-62mm-24h2 lists affected ranges: PyPI apache-airflow >=0 <2.9.2) Commands are suggestions: review each one before running it.
Loading voting…