Skip to content

← Actionable
Critical, CVSS 9.1amended

Flask-AppBuilder vulnerable to incorrect authentication when using auth type OpenID

CVE-2024-25128GHSA-j2pw-vp55-fqqj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flask-appbuilder 4.3.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2024-25128: 0.86% estimated exploitation activity in the next 30 days; percentile 58.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When Flask-AppBuilder is set to AUTH_TYPE AUTH_OID, allows an attacker to forge an HTTP request, that could deceive the backend into using any requested OpenID service. This vulnerability could grant an attacker unauthorised privilege access if a custom OpenID service is deployed by the attacker and accessible by the backend. This vulnerability is only exploitable when the application is using the old (deprecated 10 years ago) OpenID 2.0 authorization protocol (which is very different from the popular OIDC - Open ID Connect - popular protocol used today). Currently, this protocol is regarded as legacy, with significantly reduced usage and not supported for several years by major authorization providers.

Patches Upgrade to Flask-AppBuilder 4.3.11

Workarounds If upgrade is not possible add the following to your config: ``` from flask import flash, redirect from flask_appbuilder import expose from flask_appbuilder.security.sqla.manager import SecurityManager from…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from osv record GHSA-j2pw-vp55-fqqj

  2. Revision 3 · amended ·

    Amended from ghsa record GHSA-j2pw-vp55-fqqj

  3. Revision 2 · amended ·

    Amended from ghsa record GHSA-j2pw-vp55-fqqj

  4. Revision 1 · created ·

    Published from osv record GHSA-j2pw-vp55-fqqj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-25128

Advisory: Flask-AppBuilder vulnerable to incorrect authentication when using auth type OpenID
IDs: CVE-2024-25128, GHSA-j2pw-vp55-fqqj
Record: https://patchnext.com/advisories/cve-2024-25128 (revision 4, source checked 28 Oct 2026, 06:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flask-appbuilder 4.3.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI flask-appbuilder: affected < 4.3.11; fixed in 4.3.11

## Suggested inspection (read-only)
- `python -m pip show flask-appbuilder`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flask-appbuilder.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-j2pw-vp55-fqqj (OSV record GHSA-j2pw-vp55-fqqj lists affected ranges: PyPI flask-appbuilder >=0 <4.3.11 (fixed))
- Verified: https://github.com/advisories/GHSA-j2pw-vp55-fqqj (GitHub-reviewed advisory GHSA-j2pw-vp55-fqqj lists affected ranges: PyPI flask-appbuilder >=0 <4.3.11)

Commands are suggestions: review each one before running it.

Loading voting…