XSS sidekiq-unique-jobs UI server vulnerability
CVE-2024-25122GHSA-cmh9-rx85-xj38
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sidekiq-unique-jobs 8.0.7, 7.1.33), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems sidekiq-unique-jobs
- Affected
- >= 8.0.0, < 8.0.7>= 6.0.0.rc7, < 7.1.33
- Fixed in
- 8.0.7, 7.1.33
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cmh9-rx85-xj38 lists affected ranges: RubyGems sidekiq-unique-jobs >=8.0.0 =6.0.0.rc7 <7.1.33
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
- EPSS
- CVE-2024-25122: 0.53% estimated exploitation activity in the next 30 days; percentile 44.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Cross site scripting (XSS) potentially exposing cookies / sessions / localStorage, fixed by sidekiq-unique-jobs v8.0.7. Specifically, this is a Reflected (Server-Side), Non-Self, Cross Site Scripting vulnerability, considered a P3 on the BugCrowd taxonomy with the following categorization: Cross-Site Scripting (XSS) Reflected Non-Self It was initially thought there was a second vulnerability (RCE), but it was a false alarm. Injection is impossible with Redis: String escaping and NoSQL injection The Redis protocol has no concept of string escaping, so injection is impossible under normal circumstances using a normal client library. The protocol uses prefixed-length strings and is completely binary safe. Ref: https://redis.io/docs/management/security/ XSS Vulnerability Specially crafted GET request parameters handled by any of the following endpoints of sidekiq-unique-jobs' "admin" web UI, allow a super-user attacker, or an unwitting, but authorized, victim, who has received a…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-cmh9-rx85-xj38
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-25122 Advisory: XSS sidekiq-unique-jobs UI server vulnerability IDs: CVE-2024-25122, GHSA-cmh9-rx85-xj38 Record: https://patchnext.com/advisories/cve-2024-25122 (revision 1, source checked 26 Oct 2026, 15:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sidekiq-unique-jobs 8.0.7, 7.1.33. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems sidekiq-unique-jobs: affected >= 8.0.0, < 8.0.7; >= 6.0.0.rc7, < 7.1.33; fixed in 8.0.7, 7.1.33 ## Suggested inspection (read-only) - RubyGems sidekiq-unique-jobs: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sidekiq-unique-jobs. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-cmh9-rx85-xj38 (GitHub-reviewed advisory GHSA-cmh9-rx85-xj38 lists affected ranges: RubyGems sidekiq-unique-jobs >=8.0.0 =6.0.0.rc7 <7.1.33) Commands are suggestions: review each one before running it.
Loading voting…