Skip to content

← Actionable
Critical, CVSS 9.9

Pixelfed doesn't check OAuth Scopes in API routes, giving elevated permissions

CVE-2024-25108GHSA-gccq-h3xj-jgvf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pixelfed/pixelfed 0.11.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.9 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:L/A:L
EPSS
  • CVE-2024-25108: 0.68% estimated exploitation activity in the next 30 days; percentile 52.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary When processing requests authorization was improperly and insufficiently checked, allowing attackers to access far more functionality than users intended, including to the administrative and moderator functionality of the Pixelfed server. This vulnerability affects every version of Pixelfed between v0.10.4 and v0.11.9, inclusive. A proof of concept of this vulnerability exists. Details In vulnerable versions of Pixelfed (versions before 0.11.11), when the API checked the request for permissions to perform a certain behavior, it did not check that the OAuth Application/Client had granted access to those API endpoints, it only checked if the user was authenticated via an access token, and if the user was the owner of the resource or an admin on the instance. This meant that an attacker could request an access token for "read" permissions to authenticate you with their application, but the access token that they obtained actually could be used for "write" or even administrative…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gccq-h3xj-jgvf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-25108

Advisory: Pixelfed doesn't check OAuth Scopes in API routes, giving elevated permissions
IDs: CVE-2024-25108, GHSA-gccq-h3xj-jgvf
Record: https://patchnext.com/advisories/cve-2024-25108 (revision 1, source checked 26 Oct 2026, 14:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pixelfed/pixelfed 0.11.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist pixelfed/pixelfed: affected >= 0.10.4, < 0.11.11; fixed in 0.11.11

## Suggested inspection (read-only)
- Packagist pixelfed/pixelfed: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pixelfed/pixelfed.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gccq-h3xj-jgvf (GitHub-reviewed advisory GHSA-gccq-h3xj-jgvf lists affected ranges: Packagist pixelfed/pixelfed >=0.10.4 <0.11.11)

Commands are suggestions: review each one before running it.

Loading voting…