Exiv2 has an out-of-bounds read in QuickTimeVideo::NikonTagsDecoder
CVE-2024-24826GHSA-g9xm-7538-mq8w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (exiv2 0.16.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI exiv2
- Affected
- >= 0.16.0, < 0.16.1
- Fixed in
- 0.16.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-g9xm-7538-mq8w lists affected ranges: PyPI exiv2 >=0.16.0 <0.16.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g9xm-7538-mq8w lists affected ranges: PyPI exiv2 >=0.16.0 <0.16.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.5 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
- EPSS
- CVE-2024-24826: 0.24% estimated exploitation activity in the next 30 days; percentile 14.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An out-of-bounds read was found in Exiv2 version v0.28.1. The vulnerable function, QuickTimeVideo::NikonTagsDecoder, was new in v0.28.0 (see https://github.com/Exiv2/exiv2/pull/2337), so Exiv2 versions before v0.28 are not affected. Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. The out-of-bounds read is triggered when Exiv2 is used to read the metadata of a crafted video file. Patches The bug is fixed in version v0.28.2. For more information Please see our security policy for information about Exiv2 security. Credit This bug was found by OSS-Fuzz.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-g9xm-7538-mq8w
- Revision 1 · created ·
Published from osv record GHSA-g9xm-7538-mq8w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-24826 Advisory: Exiv2 has an out-of-bounds read in QuickTimeVideo::NikonTagsDecoder IDs: CVE-2024-24826, GHSA-g9xm-7538-mq8w Record: https://patchnext.com/advisories/cve-2024-24826 (revision 2, source checked 26 Oct 2026, 13:22 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: exiv2 0.16.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI exiv2: affected >= 0.16.0, < 0.16.1; fixed in 0.16.1 ## Suggested inspection (read-only) - `python -m pip show exiv2`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on exiv2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-g9xm-7538-mq8w (OSV record GHSA-g9xm-7538-mq8w lists affected ranges: PyPI exiv2 >=0.16.0 <0.16.1 (fixed)) - Verified: https://github.com/advisories/GHSA-g9xm-7538-mq8w (GitHub-reviewed advisory GHSA-g9xm-7538-mq8w lists affected ranges: PyPI exiv2 >=0.16.0 <0.16.1) Commands are suggestions: review each one before running it.
Loading voting…