Skip to content

← Actionable
High, CVSS 8.8

Graylog vulnerable to instantiation of arbitrary classes triggered by API request

CVE-2024-24824GHSA-p6gg-5hf4-4rgj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.graylog2:graylog2-server 5.2.4, 5.1.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2024-24824: 34.74% estimated exploitation activity in the next 30 days; percentile 98.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Arbitrary classes can be loaded and instantiated using a HTTP PUT request to the /api/system/clusterconfig/ endpoint. Details Graylog's cluster config system uses fully qualified class names as config keys. To validate the existence of the requested class before using them, Graylog loads the class using the class loader. https://github.com/Graylog2/graylog2-server/blob/e458db8bf4f789d4d19f1b37f0263f910c8d036c/graylog2-server/src/main/java/org/graylog2/rest/resources/system/ClusterConfigResource.java#L208-L214 PoC A request of the following form will output the content of the /etc/passwd file: To perform the request, authorization is required. Only users posessing the clusterconfigentry:create and clusterconfigentry:edit permissions are allowed to do so. These permissions are usually only granted to Admin users. Impact If a user with the appropriate permissions performs the request, arbitrary classes with 1-arg String constructors can be instantiated. This will execute…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-p6gg-5hf4-4rgj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-24824

Advisory: Graylog vulnerable to instantiation of arbitrary classes triggered by API request
IDs: CVE-2024-24824, GHSA-p6gg-5hf4-4rgj
Record: https://patchnext.com/advisories/cve-2024-24824 (revision 1, source checked 26 Oct 2026, 16:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.graylog2:graylog2-server 5.2.4, 5.1.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.graylog2:graylog2-server: affected >= 2.0.0, < 5.1.11; >= 5.2.0-alpha.1, < 5.2.4; fixed in 5.2.4, 5.1.11

## Suggested inspection (read-only)
- Maven org.graylog2:graylog2-server: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.graylog2:graylog2-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-p6gg-5hf4-4rgj (GitHub-reviewed advisory GHSA-p6gg-5hf4-4rgj lists affected ranges: Maven org.graylog2:graylog2-server >=2.0.0 =5.2.0-alpha.1 <5.2.4)

Commands are suggestions: review each one before running it.

Loading voting…