CKEditor4 Cross-site Scripting vulnerability in samples with enabled the preview feature
CVE-2024-24816GHSA-mw2c-vx6j-mg76
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ckeditor4 4.24.0-lts), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm ckeditor4
- Affected
- < 4.24.0-lts
- Fixed in
- 4.24.0-lts
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mw2c-vx6j-mg76 lists affected ranges: npm ckeditor4 >=0 <4.24.0-lts (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mw2c-vx6j-mg76 lists affected ranges: npm ckeditor4 >=0 <4.24.0-lts
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2024-24816: 1.65% estimated exploitation activity in the next 30 days; percentile 76.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected packages The vulnerability has been discovered in the samples that use the preview feature: samples/old//.html plugins/[plugin name]/samples//.html All integrators that use these samples in the production code can be affected. Impact A potential vulnerability has been discovered in one of CKEditor's 4 samples that are shipped with production code. The vulnerability allowed to execute JavaScript code by abusing the misconfigured preview feature. It affects all users using the CKEditor 4 at version < 4.24.0-lts with affected samples used in a production environment. Patches The problem has been recognized and patched. The fix will be available in version 4.24.0-lts. For more information Email us at security@cksource.com if you have any questions or comments about this advisory. Acknowledgements The CKEditor 4 team would like to thank Marcin Wyczechowski & Michał Majchrowicz AFINE Team for recognizing and reporting this vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-mw2c-vx6j-mg76
- Revision 1 · created ·
Published from osv record GHSA-mw2c-vx6j-mg76
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-24816 Advisory: CKEditor4 Cross-site Scripting vulnerability in samples with enabled the preview feature IDs: CVE-2024-24816, GHSA-mw2c-vx6j-mg76 Record: https://patchnext.com/advisories/cve-2024-24816 (revision 2, source checked 26 Oct 2026, 12:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ckeditor4 4.24.0-lts. A vendor fix does not mean a deployment is fixed. ## Affected components - npm ckeditor4: affected < 4.24.0-lts; fixed in 4.24.0-lts ## Suggested inspection (read-only) - `npm ls ckeditor4 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ckeditor4. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mw2c-vx6j-mg76 (OSV record GHSA-mw2c-vx6j-mg76 lists affected ranges: npm ckeditor4 >=0 <4.24.0-lts (fixed)) - Verified: https://github.com/advisories/GHSA-mw2c-vx6j-mg76 (GitHub-reviewed advisory GHSA-mw2c-vx6j-mg76 lists affected ranges: npm ckeditor4 >=0 <4.24.0-lts) Commands are suggestions: review each one before running it.
Loading voting…