Sulu HTML Injection via Autocomplete Suggestion
CVE-2024-24807GHSA-gfrh-gwqc-63cv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sulu/sulu 2.5.12, 2.4.16), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist sulu/sulu
- Affected
- >= 2.0.0, < 2.4.16>= 2.5.0, < 2.5.12
- Fixed in
- 2.4.16, 2.5.12
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gfrh-gwqc-63cv lists affected ranges: Packagist sulu/sulu >=2.0.0 =2.5.0 <2.5.12
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2024-24807: 0.52% estimated exploitation activity in the next 30 days; percentile 44.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact It is an issue when input HTML into the Tag name. The HTML is execute when the tag name is listed in the auto complete form. Only admin users are affected and only admin users can create tags. Patches Has the problem been patched? What versions should users upgrade to? The problem is patched with Version 2.4.16 and 2.5.12. Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? Create a custom mutation observer References Are there any links users can visit to find out more? Currently not. For more information If you have any questions or comments about this advisory: - Open an issue in sulu/sulu repository - Email us at security@sulu.io
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-gfrh-gwqc-63cv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-24807 Advisory: Sulu HTML Injection via Autocomplete Suggestion IDs: CVE-2024-24807, GHSA-gfrh-gwqc-63cv Record: https://patchnext.com/advisories/cve-2024-24807 (revision 1, source checked 26 Oct 2026, 14:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sulu/sulu 2.5.12, 2.4.16. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist sulu/sulu: affected >= 2.0.0, < 2.4.16; >= 2.5.0, < 2.5.12; fixed in 2.4.16, 2.5.12 ## Suggested inspection (read-only) - Packagist sulu/sulu: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sulu/sulu. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gfrh-gwqc-63cv (GitHub-reviewed advisory GHSA-gfrh-gwqc-63cv lists affected ranges: Packagist sulu/sulu >=2.0.0 =2.5.0 <2.5.12) Commands are suggestions: review each one before running it.
Loading voting…