Vantage6: No limit on emails sent for password/MFA reset
CVE-2024-24769GHSA-5549-c5q7-fj65
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vantage6 5.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI vantage6
- Affected
- < 5.0.0
- Fixed in
- 5.0.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5549-c5q7-fj65 lists affected ranges: PyPI vantage6 >=0 <5.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5549-c5q7-fj65 lists affected ranges: PyPI vantage6 >=0 <5.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-24769: 0.28% estimated exploitation activity in the next 30 days; percentile 20.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Users can reset their MFA token via API routes that send them an email. Currently the number of emails that is sent is not limited. This gives attackers the option to flood someones mailbox with a lot of emails, and would have adverse effects on the SMTP server which may be seen as spam sender. Note resetting the MFA token requires a correct password, so the potential impact for this is very low.
Patches No
Workarounds No
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 5 · amended ·
Amended from osv record GHSA-5549-c5q7-fj65
- Revision 4 · amended ·
Amended from ghsa record GHSA-5549-c5q7-fj65
- Revision 3 · amended ·
Amended from ghsa record GHSA-5549-c5q7-fj65
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-5549-c5q7-fj65
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-24769 Advisory: Vantage6: No limit on emails sent for password/MFA reset IDs: CVE-2024-24769, GHSA-5549-c5q7-fj65 Record: https://patchnext.com/advisories/cve-2024-24769 (revision 5, source checked 4 Nov 2026, 06:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vantage6 5.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI vantage6: affected < 5.0.0; fixed in 5.0.0 ## Suggested inspection (read-only) - `python -m pip show vantage6`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vantage6. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5549-c5q7-fj65 (OSV record GHSA-5549-c5q7-fj65 lists affected ranges: PyPI vantage6 >=0 <5.0.0 (fixed)) - Verified: https://github.com/advisories/GHSA-5549-c5q7-fj65 (GitHub-reviewed advisory GHSA-5549-c5q7-fj65 lists affected ranges: PyPI vantage6 >=0 <5.0.0) Commands are suggestions: review each one before running it.
Loading voting…