October System module has an Open Redirect for Administrator Accounts
CVE-2024-24764GHSA-v2vf-jv88-3fp5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (october/system 3.5.15), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist october/system
- Affected
- >= 3.2, < 3.5.15
- Fixed in
- 3.5.15
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v2vf-jv88-3fp5 lists affected ranges: Packagist october/system >=3.2 <3.5.15
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.5 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:N/A:L
- EPSS
- CVE-2024-24764: 0.27% estimated exploitation activity in the next 30 days; percentile 18.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact This advisory affects authenticated administrators who may be redirected to an untrusted URL using the PageFinder schema. The resolver for the page finder link schema (october://) allowed external links, therefore allowing an open redirect outside the scope of the active host. This vulnerability assumes a trusted user will attack another trusted user and cannot be actively exploited without access to the administration panel and interaction from the other user. Patches This issue has been patched in v3.5.15. References Credits to: - Benzetaa For more information If you have any questions or comments about this advisory: Email us at hello@octobercms.com
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-v2vf-jv88-3fp5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-24764 Advisory: October System module has an Open Redirect for Administrator Accounts IDs: CVE-2024-24764, GHSA-v2vf-jv88-3fp5 Record: https://patchnext.com/advisories/cve-2024-24764 (revision 1, source checked 26 Oct 2026, 14:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: october/system 3.5.15. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist october/system: affected >= 3.2, < 3.5.15; fixed in 3.5.15 ## Suggested inspection (read-only) - Packagist october/system: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on october/system. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-v2vf-jv88-3fp5 (GitHub-reviewed advisory GHSA-v2vf-jv88-3fp5 lists affected ranges: Packagist october/system >=3.2 <3.5.15) Commands are suggestions: review each one before running it.
Loading voting…