PYSEC-2024-38
CVE-2024-24762GHSA-2jv5-9r88-3w3p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (python-multipart 0.0.7; fastapi 0.109.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI python-multipart
- Affected
- < 0.0.7
- Fixed in
- 0.0.7
PyPI fastapi
- Affected
- < 0.109.1
- Fixed in
- 0.109.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2jv5-9r88-3w3p lists affected ranges: PyPI python-multipart >=0 <0.0.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record PYSEC-2024-38 lists affected ranges: PyPI fastapi >=0 <0.109.1 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2024-24762: 1.52% estimated exploitation activity in the next 30 days; percentile 74.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
FastAPI is a web framework for building APIs with Python 3.8+ based on standard Python type hints. When using form data, `python-multipart` uses a Regular Expression to parse the HTTP `Content-Type` header, including options. An attacker could send a custom-made `Content-Type` option that is very difficult for the RegEx to process, consuming CPU resources and stalling indefinitely (minutes or more) while holding the main event loop. This means that process can't handle any more requests. It's a ReDoS(Regular expression Denial of Service), it only applies to those reading form data, using `python-multipart`. This vulnerability has been patched in version 0.109.1.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from osv record PYSEC-2024-38
- Revision 1 · created ·
Published from osv record GHSA-2jv5-9r88-3w3p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-24762 Advisory: PYSEC-2024-38 IDs: CVE-2024-24762, GHSA-2jv5-9r88-3w3p Record: https://patchnext.com/advisories/cve-2024-24762 (revision 2, source checked 24 Oct 2026, 04:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: python-multipart 0.0.7; fastapi 0.109.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI python-multipart: affected < 0.0.7; fixed in 0.0.7 - PyPI fastapi: affected < 0.109.1; fixed in 0.109.1 ## Suggested inspection (read-only) - `python -m pip show python-multipart`: prints the installed version. Run with the environment that serves production active. - `python -m pip show fastapi`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on python-multipart, fastapi. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-2jv5-9r88-3w3p (OSV record GHSA-2jv5-9r88-3w3p lists affected ranges: PyPI python-multipart >=0 <0.0.7 (fixed)) - Verified: https://osv.dev/vulnerability/PYSEC-2024-38 (OSV record PYSEC-2024-38 lists affected ranges: PyPI fastapi >=0 <0.109.1 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…