derhansen/sf_event_mgt vulnerable to Broken Access Control in Backend Module
CVE-2024-24751GHSA-4576-pgh2-g34j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (derhansen/sf_event_mgt 7.4.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist derhansen/sf_event_mgt
- Affected
- >= 7.0.0, < 7.4.0
- Fixed in
- 7.4.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4576-pgh2-g34j lists affected ranges: Packagist derhansen/sf_event_mgt >=7.0.0 <7.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2024-24751: 0.48% estimated exploitation activity in the next 30 days; percentile 41.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The existing access control check for events in the backend module got broken during the update of the extension to TYPO3 12.4, because the RedirectResponse from the $this-redirect() function was never handled.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4576-pgh2-g34j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-24751 Advisory: derhansen/sf_event_mgt vulnerable to Broken Access Control in Backend Module IDs: CVE-2024-24751, GHSA-4576-pgh2-g34j Record: https://patchnext.com/advisories/cve-2024-24751 (revision 1, source checked 26 Oct 2026, 14:28 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: derhansen/sf_event_mgt 7.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist derhansen/sf_event_mgt: affected >= 7.0.0, < 7.4.0; fixed in 7.4.0 ## Suggested inspection (read-only) - Packagist derhansen/sf_event_mgt: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on derhansen/sf_event_mgt. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4576-pgh2-g34j (GitHub-reviewed advisory GHSA-4576-pgh2-g34j lists affected ranges: Packagist derhansen/sf_event_mgt >=7.0.0 <7.4.0) Commands are suggestions: review each one before running it.
Loading voting…