phpMyFAQ vulnerable to stored XSS on attachments filename
CVE-2024-24574GHSA-7m8g-fprr-47fx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpmyfaq/phpmyfaq 3.2.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist phpmyfaq/phpmyfaq
- Affected
- < 3.2.5
- Fixed in
- 3.2.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7m8g-fprr-47fx lists affected ranges: Packagist phpmyfaq/phpmyfaq >=0 <3.2.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L
- EPSS
- CVE-2024-24574: 0.88% estimated exploitation activity in the next 30 days; percentile 59.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Unsafe echo of filename in phpMyFAQ\phpmyfaq\admin\attachments.php leading to allow execute JavaScript code in client side (XSS) Details On that snippet code of rendering the file attachments from user tables The data directly rendering with short hand echo without any sanitation first, its recommend to use existing class of Strings::htmlentities on use phpMyFAQ\Strings; Propose fixing on that pull request https://github.com/thorsten/phpMyFAQ/pull/2827 PoC 1. An attacker with permission will upload the attachments image on http://{baseurl}/admin/?action=editentry 2. On endpoint of ajax upload image POST /admin/index.php?action=ajax&ajax=att&ajaxaction=upload 3. Change the originally name file on parameters filename to a XSS payload 4. The XSS will trigger on attachment pages /admin/?action=attachments - Trigger XSS - Payload XSS <img width="1000" alt="image" src="https://user-images.githubusercontent.com/37658579/301022571-d6cdd166-b1f9-4062-87c5-c8bbb308cd5d.png" Impact This…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-7m8g-fprr-47fx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-24574 Advisory: phpMyFAQ vulnerable to stored XSS on attachments filename IDs: CVE-2024-24574, GHSA-7m8g-fprr-47fx Record: https://patchnext.com/advisories/cve-2024-24574 (revision 1, source checked 26 Oct 2026, 14:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: phpmyfaq/phpmyfaq 3.2.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist phpmyfaq/phpmyfaq: affected < 3.2.5; fixed in 3.2.5 ## Suggested inspection (read-only) - Packagist phpmyfaq/phpmyfaq: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on phpmyfaq/phpmyfaq. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7m8g-fprr-47fx (GitHub-reviewed advisory GHSA-7m8g-fprr-47fx lists affected ranges: Packagist phpmyfaq/phpmyfaq >=0 <3.2.5) Commands are suggestions: review each one before running it.
Loading voting…