Skip to content

← Actionable
High, CVSS 8.2

Statmic CMS vulnerable to account takeover via XSS and password reset link

CVE-2024-24570GHSA-vqxq-hvxw-9mv9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (statamic/cms 4.46.0, 3.4.17), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist statamic/cms

    Affected
    >= 4.00, < 4.46.0< 3.4.17
    Fixed in
    3.4.17, 4.46.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:L/A:N
EPSS
  • CVE-2024-24570: 0.73% estimated exploitation activity in the next 30 days; percentile 54.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact HTML files crafted to look like jpg files are able to be uploaded, allowing for XSS. This affects: - front-end forms with asset fields without any mime type validation - asset fields in the control panel - asset browser in the control panel Additionally, if the XSS is crafted in a specific way, the "copy password reset link" feature may be exploited to gain access to a user's password reset token and gain access to their account. The authorized user is required to execute the XSS in order for the vulnerability to occur. Patches In versions 4.46.0 and 3.4.17, the XSS vulnerability has been patched, and the copy password reset link functionality has been disabled. (Users may still trigger password reset emails.) Credits Statamic thanks Niklas Schilling (discovery, analysis, coordination) from the SEC Consult Vulnerability Lab (https://www.sec-consult.com/) for responsibly reporting the identified issues and working with us as we addressed them.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vqxq-hvxw-9mv9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-24570

Advisory: Statmic CMS vulnerable to account takeover via XSS and password reset link
IDs: CVE-2024-24570, GHSA-vqxq-hvxw-9mv9
Record: https://patchnext.com/advisories/cve-2024-24570 (revision 1, source checked 26 Oct 2026, 14:18 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: statamic/cms 4.46.0, 3.4.17. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist statamic/cms: affected >= 4.00, < 4.46.0; < 3.4.17; fixed in 3.4.17, 4.46.0

## Suggested inspection (read-only)
- Packagist statamic/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on statamic/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vqxq-hvxw-9mv9 (GitHub-reviewed advisory GHSA-vqxq-hvxw-9mv9 lists affected ranges: Packagist statamic/cms >=4.00 =0 <3.4.17)

Commands are suggestions: review each one before running it.

Loading voting…