@lobehub/chat vulnerable to unauthorized access to plugins
CVE-2024-24566GHSA-pf55-fj96-xf37
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@lobehub/chat 0.122.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @lobehub/chat
- Affected
- <= 0.122.3
- Fixed in
- 0.122.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pf55-fj96-xf37 lists affected ranges: npm @lobehub/chat >=0 <0.122.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pf55-fj96-xf37 lists affected ranges: npm @lobehub/chat >=0 <=0.122.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2024-24566: 0.48% estimated exploitation activity in the next 30 days; percentile 41.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description: When the application is password-protected (deployed with the ACCESSCODE option), it is possible to access plugins without proper authorization (without password). Proof-of-Concept: Let’s suppose that application has been deployed with following command: Due to the utilization of the ACCESSCODE, access to the chat is possible only after entering the password: However, it is possible to interact with chat plugins without entering the ACCESSCODE. Example HTTP request: HTTP response: Remediation: Verify the ACCESSCODE for HTTP requests to the /api/plugin/: route. Impact: Unauthorized access to plugins.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-pf55-fj96-xf37
- Revision 1 · created ·
Published from osv record GHSA-pf55-fj96-xf37
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-24566 Advisory: @lobehub/chat vulnerable to unauthorized access to plugins IDs: CVE-2024-24566, GHSA-pf55-fj96-xf37 Record: https://patchnext.com/advisories/cve-2024-24566 (revision 2, source checked 26 Oct 2026, 12:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @lobehub/chat 0.122.4. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @lobehub/chat: affected <= 0.122.3; fixed in 0.122.4 ## Suggested inspection (read-only) - `npm ls @lobehub/chat --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @lobehub/chat. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pf55-fj96-xf37 (OSV record GHSA-pf55-fj96-xf37 lists affected ranges: npm @lobehub/chat >=0 <0.122.4 (fixed)) - Verified: https://github.com/advisories/GHSA-pf55-fj96-xf37 (GitHub-reviewed advisory GHSA-pf55-fj96-xf37 lists affected ranges: npm @lobehub/chat >=0 <=0.122.3) Commands are suggestions: review each one before running it.
Loading voting…