Skip to content

← Actionable
Medium, CVSS 6.9

Classic builder cache poisoning

CVE-2024-24557GHSA-xw73-rw38-6vjc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/docker/docker 25.0.2, 24.0.9; github.com/moby/moby 25.0.2, 24.0.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.9 · CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:C/C:L/I:H/A:L
EPSS
  • CVE-2024-24557: 0.26% estimated exploitation activity in the next 30 days; percentile 17.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The classic builder cache system is prone to cache poisoning if the image is built FROM scratch. Also, changes to some instructions (most important being HEALTHCHECK and ONBUILD) would not cause a cache miss. An attacker with the knowledge of the Dockerfile someone is using could poison their cache by making them pull a specially crafted image that would be considered as a valid cache candidate for some build steps. For example, an attacker could create an image that is considered as a valid cache candidate for: when in fact the malicious image used as a cache would be an image built from a different Dockerfile. In the second case, the attacker could for example substitute a different HEALTCHECK command. Impact 23.0+ users are only affected if they explicitly opted out of Buildkit (DOCKERBUILDKIT=0 environment variable) or are using the /build API endpoint (which uses the classic builder by default). All users on versions older than 23.0 could be impacted. An example could be a CI…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-xw73-rw38-6vjc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-24557

Advisory: Classic builder cache poisoning
IDs: CVE-2024-24557, GHSA-xw73-rw38-6vjc
Record: https://patchnext.com/advisories/cve-2024-24557 (revision 1, source checked 26 Oct 2026, 15:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/docker/docker 25.0.2, 24.0.9; github.com/moby/moby 25.0.2, 24.0.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/docker/docker: affected >= 25.0.0, < 25.0.2; < 24.0.9; fixed in 25.0.2, 24.0.9
- Go github.com/moby/moby: affected < 24.0.9; >= 25.0.0, < 25.0.2; fixed in 25.0.2, 24.0.9

## Suggested inspection (read-only)
- Go github.com/docker/docker: check the installed version with your package manager.
- Go github.com/moby/moby: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/docker/docker, github.com/moby/moby.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xw73-rw38-6vjc (GitHub-reviewed advisory GHSA-xw73-rw38-6vjc lists affected ranges: Go github.com/docker/docker >=25.0.0 =0 =0 =25.0.0 <25.0.2)

Commands are suggestions: review each one before running it.

Loading voting…