Skip to content

← Actionable
Medium, CVSS 6.6

Apache Tomcat Denial of Service due to improper input validation vulnerability for HTTP/2 requests

CVE-2024-24549GHSA-7w75-32cg-r6g2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tomcat:tomcat-coyote 11.0.0-M17, 10.1.19, 9.0.86, 8.5.99; org.apache.tomcat.embed:tomcat-embed-core 11.0.0-M17, 10.1.19, 9.0.86, 8.5.99), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.apache.tomcat:tomcat-coyote

    Affected
    >= 11.0.0-M1, <= 11.0.0-M16>= 10.1.0-M1, <= 10.1.18>= 9.0.0-M1, <= 9.0.85>= 8.5.0, <= 8.5.98
    Fixed in
    9.0.86, 11.0.0-M17, 10.1.19, 8.5.99
  • Maven org.apache.tomcat.embed:tomcat-embed-core

    Affected
    >= 8.5.0, <= 8.5.98>= 9.0.0-M1, <= 9.0.85>= 10.1.0-M1, <= 10.1.18>= 11.0.0-M1, <= 11.0.0-M16
    Fixed in
    9.0.86, 11.0.0-M17, 10.1.19, 8.5.99

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-7w75-32cg-r6g2 lists affected ranges: Maven org.apache.tomcat.embed:tomcat-embed-core >=8.5.0 =9.0.0-M1 =10.1.0-M1 =11.0.0-M1 =11.0.0-M1 =10.1.0-M1 =9.0.0-M1 =8.5.0 <=8.5.98

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U · score source
EPSS
  • CVE-2024-24549: 23.07% estimated exploitation activity in the next 30 days; percentile 97.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Denial of Service due to improper input validation vulnerability for HTTP/2 requests in Apache Tomcat. When processing an HTTP/2 request, if the request exceeded any of the configured limits for headers, the associated HTTP/2 stream was not reset until after all of the headers had been processed.This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M16, from 10.1.0-M1 through 10.1.18, from 9.0.0-M1 through 9.0.85, from 8.5.0 through 8.5.98. Users are recommended to upgrade to version 11.0.0-M17, 10.1.19, 9.0.86 or 8.5.99 which fix the issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-7w75-32cg-r6g2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-24549

Advisory: Apache Tomcat Denial of Service due to improper input validation vulnerability for HTTP/2 requests
IDs: CVE-2024-24549, GHSA-7w75-32cg-r6g2
Record: https://patchnext.com/advisories/cve-2024-24549 (revision 1, source checked 26 Oct 2026, 16:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.tomcat:tomcat-coyote 11.0.0-M17, 10.1.19, 9.0.86, 8.5.99; org.apache.tomcat.embed:tomcat-embed-core 11.0.0-M17, 10.1.19, 9.0.86, 8.5.99. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.tomcat:tomcat-coyote: affected >= 11.0.0-M1, <= 11.0.0-M16; >= 10.1.0-M1, <= 10.1.18; >= 9.0.0-M1, <= 9.0.85; >= 8.5.0, <= 8.5.98; fixed in 9.0.86, 11.0.0-M17, 10.1.19, 8.5.99
- Maven org.apache.tomcat.embed:tomcat-embed-core: affected >= 8.5.0, <= 8.5.98; >= 9.0.0-M1, <= 9.0.85; >= 10.1.0-M1, <= 10.1.18; >= 11.0.0-M1, <= 11.0.0-M16; fixed in 9.0.86, 11.0.0-M17, 10.1.19, 8.5.99

## Suggested inspection (read-only)
- Maven org.apache.tomcat:tomcat-coyote: check the installed version with your package manager.
- Maven org.apache.tomcat.embed:tomcat-embed-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.tomcat:tomcat-coyote, org.apache.tomcat.embed:tomcat-embed-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7w75-32cg-r6g2 (GitHub-reviewed advisory GHSA-7w75-32cg-r6g2 lists affected ranges: Maven org.apache.tomcat.embed:tomcat-embed-core >=8.5.0 =9.0.0-M1 =10.1.0-M1 =11.0.0-M1 =11.0.0-M1 =10.1.0-M1 =9.0.0-M1 =8.5.0 <=8.5.98)

Commands are suggestions: review each one before running it.

Loading voting…