Path traversal in flaskcode Devan-Kerman ARRP
CVE-2024-24042GHSA-cg24-jjr5-rxmf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (net.devtech:arrp 0.8.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven net.devtech:arrp
- Affected
- <= 0.8.1
- Fixed in
- 0.8.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cg24-jjr5-rxmf lists affected ranges: Maven net.devtech:arrp >=0 <=0.8.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2024-24042: 1.36% estimated exploitation activity in the next 30 days; percentile 71.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Directory Traversal vulnerability in Devan-Kerman ARRP v.0.8.1 and before allows a remote attacker to execute arbitrary code via the dumpDirect in RuntimeResourcePackImpl component.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-cg24-jjr5-rxmf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-24042 Advisory: Path traversal in flaskcode Devan-Kerman ARRP IDs: CVE-2024-24042, GHSA-cg24-jjr5-rxmf Record: https://patchnext.com/advisories/cve-2024-24042 (revision 1, source checked 26 Oct 2026, 16:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: net.devtech:arrp 0.8.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven net.devtech:arrp: affected <= 0.8.1; fixed in 0.8.2 ## Suggested inspection (read-only) - Maven net.devtech:arrp: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on net.devtech:arrp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-cg24-jjr5-rxmf (GitHub-reviewed advisory GHSA-cg24-jjr5-rxmf lists affected ranges: Maven net.devtech:arrp >=0 <=0.8.1) Commands are suggestions: review each one before running it.
Loading voting…