Apache Hive vulnerable to Observable Timing Discrepancy and Authentication Bypass by Spoofing
CVE-2024-23953GHSA-p953-3j66-hg45
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.hive:hive-llap-common 4.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.hive:hive-llap-common
- Affected
- < 4.0.0
- Fixed in
- 4.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p953-3j66-hg45 lists affected ranges: Maven org.apache.hive:hive-llap-common >=0 <4.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2024-23953: 1.31% estimated exploitation activity in the next 30 days; percentile 70.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Use of Arrays.equals() in LlapSignerImpl in Apache Hive to compare message signatures allows attacker to forge a valid signature for an arbitrary message byte by byte. The attacker should be an authorized user of the product to perform this attack. Users are recommended to upgrade to version 4.0.0, which fixes this issue. The problem occurs when an application doesn’t use a constant-time algorithm for validating a signature. The method Arrays.equals() returns false right away when it sees that one of the input’s bytes are different. It means that the comparison time depends on the contents of the arrays. This little thing may allow an attacker to forge a valid signature for an arbitrary message byte by byte. So it might allow malicious users to submit splits/work with selected signatures to LLAP without running as a privileged user, potentially leading to DDoS attack. More details in the reference section.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-p953-3j66-hg45
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-23953 Advisory: Apache Hive vulnerable to Observable Timing Discrepancy and Authentication Bypass by Spoofing IDs: CVE-2024-23953, GHSA-p953-3j66-hg45 Record: https://patchnext.com/advisories/cve-2024-23953 (revision 1, source checked 26 Oct 2026, 16:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.hive:hive-llap-common 4.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.hive:hive-llap-common: affected < 4.0.0; fixed in 4.0.0 ## Suggested inspection (read-only) - Maven org.apache.hive:hive-llap-common: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.hive:hive-llap-common. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-p953-3j66-hg45 (GitHub-reviewed advisory GHSA-p953-3j66-hg45 lists affected ranges: Maven org.apache.hive:hive-llap-common >=0 <4.0.0) Commands are suggestions: review each one before running it.
Loading voting…