Skip to content

← Actionable
High, CVSS 8.0

Content-Security-Policy disabled by Red Hat Dependency Analytics Jenkins Plugin

CVE-2024-23905GHSA-x22x-5pp9-8v7f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.jenkins.plugins:redhat-dependency-analytics 0.9.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.0 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2024-23905: 0.56% estimated exploitation activity in the next 30 days; percentile 46.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Jenkins sets the Content-Security-Policy header to static files served by Jenkins (specifically DirectoryBrowserSupport), such as workspaces, /userContent, or archived artifacts, unless a Resource Root URL is specified. Red Hat Dependency Analytics Plugin 0.7.1 and earlier globally disables the Content-Security-Policy header for static files served by Jenkins whenever the 'Invoke Red Hat Dependency Analytics (RHDA)' build step is executed. This allows cross-site scripting (XSS) attacks by users with the ability to control files in workspaces, archived artifacts, etc.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-x22x-5pp9-8v7f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-23905

Advisory: Content-Security-Policy disabled by Red Hat Dependency Analytics Jenkins Plugin
IDs: CVE-2024-23905, GHSA-x22x-5pp9-8v7f
Record: https://patchnext.com/advisories/cve-2024-23905 (revision 1, source checked 26 Oct 2026, 16:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: io.jenkins.plugins:redhat-dependency-analytics 0.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven io.jenkins.plugins:redhat-dependency-analytics: affected < 0.9.0; fixed in 0.9.0

## Suggested inspection (read-only)
- Maven io.jenkins.plugins:redhat-dependency-analytics: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on io.jenkins.plugins:redhat-dependency-analytics.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x22x-5pp9-8v7f (GitHub-reviewed advisory GHSA-x22x-5pp9-8v7f lists affected ranges: Maven io.jenkins.plugins:redhat-dependency-analytics >=0 <0.9.0)

Commands are suggestions: review each one before running it.

Loading voting…