Clickjacking in zenml
CVE-2024-2383GHSA-mq73-g4qr-fgcq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (zenml 0.56.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI zenml
- Affected
- < 0.56.3
- Fixed in
- 0.56.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mq73-g4qr-fgcq lists affected ranges: PyPI zenml >=0 <0.56.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mq73-g4qr-fgcq lists affected ranges: PyPI zenml >=0 <0.56.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- EPSS
- CVE-2024-2383: 0.36% estimated exploitation activity in the next 30 days; percentile 29.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A clickjacking vulnerability exists in zenml-io/zenml versions up to and including 0.55.5 due to the application's failure to set appropriate X-Frame-Options or Content-Security-Policy HTTP headers. This vulnerability allows an attacker to embed the application UI within an iframe on a malicious page, potentially leading to unauthorized actions by tricking users into interacting with the interface under the attacker's control. The issue was addressed in version 0.56.3.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-mq73-g4qr-fgcq
- Revision 1 · created ·
Published from osv record GHSA-mq73-g4qr-fgcq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-2383 Advisory: Clickjacking in zenml IDs: CVE-2024-2383, GHSA-mq73-g4qr-fgcq Record: https://patchnext.com/advisories/cve-2024-2383 (revision 2, source checked 26 Oct 2026, 13:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: zenml 0.56.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI zenml: affected < 0.56.3; fixed in 0.56.3 ## Suggested inspection (read-only) - `python -m pip show zenml`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on zenml. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mq73-g4qr-fgcq (OSV record GHSA-mq73-g4qr-fgcq lists affected ranges: PyPI zenml >=0 <0.56.3 (fixed)) - Verified: https://github.com/advisories/GHSA-mq73-g4qr-fgcq (GitHub-reviewed advisory GHSA-mq73-g4qr-fgcq lists affected ranges: PyPI zenml >=0 <0.56.3) Commands are suggestions: review each one before running it.
Loading voting…