Skip to content

← Actionable
Medium, CVSS 6.9amended

aiohttp's HTTP parser (the python one, not llhttp) still overly lenient about separators

CVE-2024-23829GHSA-8qpw-xqxj-h4r2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (aiohttp 3.9.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI aiohttp

    Affected
    < 3.9.2
    Fixed in
    3.9.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-23829: 1.03% estimated exploitation activity in the next 30 days; percentile 63.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Security-sensitive parts of the Python HTTP parser retained minor differences in allowable character sets, that must trigger error handling to robustly match frame boundaries of proxies in order to protect against injection of additional requests. Additionally, validation could trigger exceptions that were not handled consistently with processing of other malformed input. Details These problems are rooted in pattern matching protocol elements, previously improved by PR #3235 and GHSA-gfw2-4jvh-wgfg: 1. The expression HTTP/(\d).(\d) lacked another backslash to clarify that the separator should be a literal dot, not just any Unicode code point (result: HTTP/(\d)\.(\d)). 2. The HTTP version was permitting Unicode digits, where only ASCII digits are standards-compliant. 3. Distinct regular expressions for validating HTTP Method and Header field names were used - though both should (at least) apply the common restrictions of rfc9110 token. PoC GET / HTTP/1ö1 GET / HTTP/1.𝟙 GET/:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-8qpw-xqxj-h4r2

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-8qpw-xqxj-h4r2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-23829

Advisory: aiohttp's HTTP parser (the python one, not llhttp) still overly lenient about separators
IDs: CVE-2024-23829, GHSA-8qpw-xqxj-h4r2
Record: https://patchnext.com/advisories/cve-2024-23829 (revision 3, source checked 26 Oct 2026, 13:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: aiohttp 3.9.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI aiohttp: affected < 3.9.2; fixed in 3.9.2

## Suggested inspection (read-only)
- `python -m pip show aiohttp`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on aiohttp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8qpw-xqxj-h4r2 (OSV record GHSA-8qpw-xqxj-h4r2 lists affected ranges: PyPI aiohttp >=0 <3.9.2 (fixed))
- Verified: https://github.com/advisories/GHSA-8qpw-xqxj-h4r2 (GitHub-reviewed advisory GHSA-8qpw-xqxj-h4r2 lists affected ranges: PyPI aiohttp >=0 <3.9.2)

Commands are suggestions: review each one before running it.

Loading voting…