Skip to content

← Actionable
Medium, CVSS 4.8

GeoServer's WMS OpenLayers Format vulnerable to Stored Cross-Site Scripting (XSS)

CVE-2024-23818GHSA-fcpm-hchj-mh72

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.geoserver:gs-wms 2.24.1, 2.23.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.8 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2024-23818: 0.43% estimated exploitation activity in the next 30 days; percentile 36.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A stored cross-site scripting (XSS) vulnerability exists that enables an authenticated administrator with workspace-level privileges to store a JavaScript payload in the GeoServer catalog that will execute in the context of another user's browser when viewed in the WMS GetMap OpenLayers Output Format. Access to the WMS OpenLayers Format is available to all users by default although data and service security may limit users' ability to trigger the XSS. Impact If an attacker can control a script that is executed in the victim's browser, then they can typically fully compromise that user. Amongst other things, the attacker can: 1 .Perform any action within the application that the user can perform. 2. View any information that the user is able to view. 3. Modify any information that the user is able to modify. 4. Initiate interactions with other application users, including malicious attacks, that will appear to originate from the initial victim user. References…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-fcpm-hchj-mh72

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-23818

Advisory: GeoServer's WMS OpenLayers Format vulnerable to Stored Cross-Site Scripting (XSS)
IDs: CVE-2024-23818, GHSA-fcpm-hchj-mh72
Record: https://patchnext.com/advisories/cve-2024-23818 (revision 1, source checked 26 Oct 2026, 16:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.geoserver:gs-wms 2.24.1, 2.23.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.geoserver:gs-wms: affected < 2.23.3; >= 2.24.0, < 2.24.1; fixed in 2.24.1, 2.23.3

## Suggested inspection (read-only)
- Maven org.geoserver:gs-wms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.geoserver:gs-wms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-fcpm-hchj-mh72 (GitHub-reviewed advisory GHSA-fcpm-hchj-mh72 lists affected ranges: Maven org.geoserver:gs-wms >=0 =2.24.0 <2.24.1)

Commands are suggestions: review each one before running it.

Loading voting…