Dolibarr Application Home Page has HTML injection vulnerability
CVE-2024-23817GHSA-7947-48q7-cp5m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (dolibarr/dolibarr 18.0.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist dolibarr/dolibarr
- Affected
- >= 18.0.4, < 18.0.7
- Fixed in
- 18.0.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7947-48q7-cp5m lists affected ranges: Packagist dolibarr/dolibarr >=18.0.4 <18.0.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N
- EPSS
- CVE-2024-23817: 0.56% estimated exploitation activity in the next 30 days; percentile 46.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Observed a HTML Injection vulnerbaility in the Home page of Dolibarr Application. This vulnerability allows an attacker to inject arbitrary HTML tags and manipulate the rendered content in the application's response. Specifically, I was able to successfully inject a new HTML tag into the returned document and, as a result, was able to comment out some part of the Dolibarr App Home page HTML code. This behavior can be exploited to perform various attacks like Cross-Site Scripting (XSS). Details 1. Navigate to the login page of Dolibarr application. 2. Submit a login request with the following payload in an arbitrarily supplied body parameter: "u70ea%22%3e%3c!--HTMLInjectionBySai"=1 HTTP Post Request: POST /dolibarr/index.php?mainmenu=home HTTP/1.1 Host: 192.168.37.129 User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:121.0) Gecko/20100101 Firefox/121.0 Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/avif,image/webp,/;q=0.8 Accept-Language:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-7947-48q7-cp5m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-23817 Advisory: Dolibarr Application Home Page has HTML injection vulnerability IDs: CVE-2024-23817, GHSA-7947-48q7-cp5m Record: https://patchnext.com/advisories/cve-2024-23817 (revision 1, source checked 26 Oct 2026, 14:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: dolibarr/dolibarr 18.0.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist dolibarr/dolibarr: affected >= 18.0.4, < 18.0.7; fixed in 18.0.7 ## Suggested inspection (read-only) - Packagist dolibarr/dolibarr: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on dolibarr/dolibarr. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7947-48q7-cp5m (GitHub-reviewed advisory GHSA-7947-48q7-cp5m lists affected ranges: Packagist dolibarr/dolibarr >=18.0.4 <18.0.7) Commands are suggestions: review each one before running it.
Loading voting…