Unsafe yaml deserialization in llama-hub
CVE-2024-23730GHSA-297x-2qf3-jrj3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (llama-hub 0.0.67), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI llama-hub
- Affected
- < 0.0.67
- Fixed in
- 0.0.67
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-297x-2qf3-jrj3 lists affected ranges: PyPI llama-hub >=0 <0.0.67 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-297x-2qf3-jrj3 lists affected ranges: PyPI llama-hub >=0 <0.0.67
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2024-23730: 1.20% estimated exploitation activity in the next 30 days; percentile 68.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The OpenAPI and ChatGPT plugin loaders in LlamaHub (aka llama-hub) before 0.0.67 allow attackers to execute arbitrary code because safe_load is not used for YAML.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from osv record GHSA-297x-2qf3-jrj3
- Revision 3 · amended ·
Amended from ghsa record GHSA-297x-2qf3-jrj3
- Revision 2 · amended ·
Amended from ghsa record GHSA-297x-2qf3-jrj3
- Revision 1 · created ·
Published from osv record GHSA-297x-2qf3-jrj3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-23730 Advisory: Unsafe yaml deserialization in llama-hub IDs: CVE-2024-23730, GHSA-297x-2qf3-jrj3 Record: https://patchnext.com/advisories/cve-2024-23730 (revision 4, source checked 28 Oct 2026, 06:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: llama-hub 0.0.67. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI llama-hub: affected < 0.0.67; fixed in 0.0.67 ## Suggested inspection (read-only) - `python -m pip show llama-hub`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on llama-hub. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-297x-2qf3-jrj3 (OSV record GHSA-297x-2qf3-jrj3 lists affected ranges: PyPI llama-hub >=0 <0.0.67 (fixed)) - Verified: https://github.com/advisories/GHSA-297x-2qf3-jrj3 (GitHub-reviewed advisory GHSA-297x-2qf3-jrj3 lists affected ranges: PyPI llama-hub >=0 <0.0.67) Commands are suggestions: review each one before running it.
Loading voting…