Denial of service in CBOR library
CVE-2024-23684GHSA-fj2w-wfgv-mwq6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.upokecenter:cbor 4.5.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.upokecenter:cbor
- Affected
- >= 4.0.0, < 4.5.1
- Fixed in
- 4.5.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fj2w-wfgv-mwq6 lists affected ranges: Maven com.upokecenter:cbor >=4.0.0 <4.5.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2024-23684: 0.92% estimated exploitation activity in the next 30 days; percentile 60.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Due to this library's use of an inefficient algorithm, it is vulnerable to a denial of service attack when a maliciously crafted input is passed to DecodeFromBytes or other CBOR decoding mechanisms in this library. Affected versions include versions 4.0.0 through 4.5.0. This vulnerability was privately reported to me. Patches This issue has been fixed in version 4.5.1. Users should use the latest version of this library. (The latest version is not necessarily 4.5.1. Check the README for this library's repository to see the latest version's version number.) Workarounds Again, users should use the latest version of this library. In the meantime, note that the inputs affected by this issue are all CBOR maps or contain CBOR maps. An input that decodes to a single CBOR object is not capable of containing a CBOR map if— - it begins with a byte other than 0x80 through 0xDF, or - it does not contain a byte in the range 0xa0 through 0xBF. Such an input is not affected by this…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fj2w-wfgv-mwq6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-23684 Advisory: Denial of service in CBOR library IDs: CVE-2024-23684, GHSA-fj2w-wfgv-mwq6 Record: https://patchnext.com/advisories/cve-2024-23684 (revision 1, source checked 26 Oct 2026, 16:44 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.upokecenter:cbor 4.5.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.upokecenter:cbor: affected >= 4.0.0, < 4.5.1; fixed in 4.5.1 ## Suggested inspection (read-only) - Maven com.upokecenter:cbor: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.upokecenter:cbor. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fj2w-wfgv-mwq6 (GitHub-reviewed advisory GHSA-fj2w-wfgv-mwq6 lists affected ranges: Maven com.upokecenter:cbor >=4.0.0 <4.5.1) Commands are suggestions: review each one before running it.
Loading voting…