Skip to content

← Actionable
Critical, CVSS 9.8

com.enonic.xp:lib-auth vulnerable to Session Fixation

CVE-2024-23679GHSA-4m5p-5w5w-3jcf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.enonic.xp:lib-auth 7.7.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2024-23679: 0.84% estimated exploitation activity in the next 30 days; percentile 57.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact All id-providers using lib-auth login method. Patches https://github.com/enonic/xp/commit/0189975691e9e6407a9fee87006f730e84f734ff https://github.com/enonic/xp/commit/2abac31cec8679074debc4f1fb69c25930e40842 https://github.com/enonic/xp/commit/1f44674eb9ab3fbab7103e8d08067846e88bace4 Workarounds Don't use lib-auth for login. Java API uses low-level structures and allows to invalidate previous session before auth-info is added. References https://github.com/enonic/xp/issues/9253

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4m5p-5w5w-3jcf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-23679

Advisory: com.enonic.xp:lib-auth vulnerable to Session Fixation
IDs: CVE-2024-23679, GHSA-4m5p-5w5w-3jcf
Record: https://patchnext.com/advisories/cve-2024-23679 (revision 1, source checked 26 Oct 2026, 16:44 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: com.enonic.xp:lib-auth 7.7.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven com.enonic.xp:lib-auth: affected < 7.7.4; fixed in 7.7.4

## Suggested inspection (read-only)
- Maven com.enonic.xp:lib-auth: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on com.enonic.xp:lib-auth.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4m5p-5w5w-3jcf (GitHub-reviewed advisory GHSA-4m5p-5w5w-3jcf lists affected ranges: Maven com.enonic.xp:lib-auth >=0 <7.7.4)

Commands are suggestions: review each one before running it.

Loading voting…