Skip to content

← Actionable
High, CVSS 7.5

Any authenticated user may obtain private message details from other users on the same instance

CVE-2024-23649GHSA-r64r-5h43-26qv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (lemmy_server 0.19.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io lemmy_server

    Affected
    >= 0.17.0, < 0.19.1
    Fixed in
    0.19.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2024-23649: 0.51% estimated exploitation activity in the next 30 days; percentile 43.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Users can report private messages, even when they're neither sender nor recipient of the message. The API response to creating a private message report contains the private message itself, which means any user can just iterate over message ids to (loudly) obtain all private messages of an instance. A user with instance admin privileges can also abuse this if the private message is removed from the response, as they're able to see the resulting reports. Details Creating a private message report by POSTing to /api/v3/privatemessage/report does not validate whether the reporter is the recipient of the message. At least lemmy-ui does not allow the sender to report the message; the API method should likely be restricted to accessible to recipients only. The API response when creating a report contains the privatemessagereportview with all the details of the report, including the private message that has been reported: <details <summaryExample response</summary In the report below,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-r64r-5h43-26qv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-23649

Advisory: Any authenticated user may obtain private message details from other users on the same instance
IDs: CVE-2024-23649, GHSA-r64r-5h43-26qv
Record: https://patchnext.com/advisories/cve-2024-23649 (revision 1, source checked 26 Oct 2026, 15:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: lemmy_server 0.19.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io lemmy_server: affected >= 0.17.0, < 0.19.1; fixed in 0.19.1

## Suggested inspection (read-only)
- crates.io lemmy_server: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on lemmy_server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-r64r-5h43-26qv (GitHub-reviewed advisory GHSA-r64r-5h43-26qv lists affected ranges: crates.io lemmy_server >=0.17.0 <0.19.1)

Commands are suggestions: review each one before running it.

Loading voting…