Host header injection in the password reset
CVE-2024-23648GHSA-mrqg-mwh7-q94j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pimcore/admin-ui-classic-bundle 1.2.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist pimcore/admin-ui-classic-bundle
- Affected
- < 1.2.3
- Fixed in
- 1.2.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mrqg-mwh7-q94j lists affected ranges: Packagist pimcore/admin-ui-classic-bundle >=0 <1.2.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2024-23648: 0.83% estimated exploitation activity in the next 30 days; percentile 57.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The password reset functionality sends to the the user requesting a password change an email containing an URL to reset its password. The URL sent contains a unique token, valid during 24 hours, allowing the user to reset its password. This token is highly sensitive ; as an attacker able to retrieve it would be able to resets the user's password. It was identified during the audit that the reset-password URL is crafted using the "Host" HTTP header of the request sent to request a password reset. This way, an external attacker could send password requests for users, but specify a "Host" header of a website that they control. If the user receiving the mail clicks on the link, the attacker would retrieve the reset token of the victim and perform account takeover. Details This attack required the server to serve Pimcore on arbitrary "Host". This configuration would be plausible if the attacker is already behind the reverse proxy. During the assessment of my client, their instance…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-mrqg-mwh7-q94j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-23648 Advisory: Host header injection in the password reset IDs: CVE-2024-23648, GHSA-mrqg-mwh7-q94j Record: https://patchnext.com/advisories/cve-2024-23648 (revision 1, source checked 26 Oct 2026, 14:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pimcore/admin-ui-classic-bundle 1.2.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist pimcore/admin-ui-classic-bundle: affected < 1.2.3; fixed in 1.2.3 ## Suggested inspection (read-only) - Packagist pimcore/admin-ui-classic-bundle: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pimcore/admin-ui-classic-bundle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-mrqg-mwh7-q94j (GitHub-reviewed advisory GHSA-mrqg-mwh7-q94j lists affected ranges: Packagist pimcore/admin-ui-classic-bundle >=0 <1.2.3) Commands are suggestions: review each one before running it.
Loading voting…