Skip to content

← Actionable
High, CVSS 7.5amended

Sending a GET or HEAD request with a body crashes SvelteKit

CVE-2024-23641GHSA-g5m6-hxpp-fc49

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@sveltejs/kit 2.4.3; @sveltejs/adapter-node 4.0.1, 3.0.3, 2.1.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2024-23641: 0.76% estimated exploitation activity in the next 30 days; percentile 55.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary In SvelteKit 2 sending a GET request with a body eg {} to a SvelteKit app in preview or with adapter-node throws Request with GET/HEAD method cannot have body. and crashes the app. TRACE requests will also cause the app to crash. Prerendered pages and SvelteKit 1 apps are not affected. <!-- Details Give all details on the vulnerability. Pointing to the incriminated source code is very helpful for the maintainer. -- PoC <!-- Complete instructions, including specific configuration details, to reproduce the vulnerability. -- First do a fresh install of SvelteKit 2 with the example app. Typescript. 1. npm run build 2. npm run preview 3. Go to http://localhost:4173 (works) 4. curl -X GET -d "{}" http://localhost:4173/bye 5. Application crashes and http://localhost:4173 is down Impact <!-- What kind of vulnerability is it? Who is impacted? -- Denial of Service for apps using adapter-node

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-g5m6-hxpp-fc49

  2. Revision 1 · created ·

    Published from osv record GHSA-g5m6-hxpp-fc49

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-23641

Advisory: Sending a GET or HEAD request with a body crashes SvelteKit
IDs: CVE-2024-23641, GHSA-g5m6-hxpp-fc49
Record: https://patchnext.com/advisories/cve-2024-23641 (revision 2, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @sveltejs/kit 2.4.3; @sveltejs/adapter-node 4.0.1, 3.0.3, 2.1.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @sveltejs/kit: affected >= 2.0.0, < 2.4.3; fixed in 2.4.3
- npm @sveltejs/adapter-node: affected >= 2.0.0, < 2.1.2; >= 3.0.0, < 3.0.3; >= 4.0.0, <= 4.0.0; fixed in 2.1.2, 3.0.3, 4.0.1

## Suggested inspection (read-only)
- `npm ls @sveltejs/kit --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @sveltejs/adapter-node --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @sveltejs/kit, @sveltejs/adapter-node.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-g5m6-hxpp-fc49 (OSV record GHSA-g5m6-hxpp-fc49 lists affected ranges: npm @sveltejs/kit >=2.0.0 =2.0.0 =3.0.0 =4.0.0 <4.0.1 (fixed))
- Verified: https://github.com/advisories/GHSA-g5m6-hxpp-fc49 (GitHub-reviewed advisory GHSA-g5m6-hxpp-fc49 lists affected ranges: npm @sveltejs/kit >=2.0.0 =2.0.0 =3.0.0 =4.0.0 <=4.0.0)

Commands are suggestions: review each one before running it.

Loading voting…