GeoServer's Style Publisher vulnerable to Stored Cross-Site Scripting (XSS)
CVE-2024-23640GHSA-9rfr-pf2x-g4xf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.geoserver:gs-ows 2.23.3; org.geoserver:gs-main 2.23.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.geoserver:gs-ows
- Affected
- < 2.23.3
- Fixed in
- 2.23.3
Maven org.geoserver:gs-main
- Affected
- < 2.23.3
- Fixed in
- 2.23.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9rfr-pf2x-g4xf lists affected ranges: Maven org.geoserver:gs-main >=0 =0 <2.23.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.8 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2024-23640: 0.43% estimated exploitation activity in the next 30 days; percentile 36.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A stored cross-site scripting (XSS) vulnerability exists that enables an authenticated administrator with workspace-level privileges to store a JavaScript payload in uploaded style/legend resources or in a specially crafted datastore file that will execute in the context of another user's browser when viewed in the Style Publisher. Access to the Style Publisher is available to all users although data security may limit users' ability to trigger the XSS. Details Give all details on the vulnerability. Pointing to the incriminated source code is very helpful for the maintainer. PoC Complete instructions, including specific configuration details, to reproduce the vulnerability. Impact If an attacker can control a script that is executed in the victim's browser, then they can typically fully compromise that user. Amongst other things, the attacker can: 1 .Perform any action within the application that the user can perform. 2. View any information that the user is able to view. 3.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9rfr-pf2x-g4xf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-23640 Advisory: GeoServer's Style Publisher vulnerable to Stored Cross-Site Scripting (XSS) IDs: CVE-2024-23640, GHSA-9rfr-pf2x-g4xf Record: https://patchnext.com/advisories/cve-2024-23640 (revision 1, source checked 26 Oct 2026, 16:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.geoserver:gs-ows 2.23.3; org.geoserver:gs-main 2.23.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.geoserver:gs-ows: affected < 2.23.3; fixed in 2.23.3 - Maven org.geoserver:gs-main: affected < 2.23.3; fixed in 2.23.3 ## Suggested inspection (read-only) - Maven org.geoserver:gs-ows: check the installed version with your package manager. - Maven org.geoserver:gs-main: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.geoserver:gs-ows, org.geoserver:gs-main. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9rfr-pf2x-g4xf (GitHub-reviewed advisory GHSA-9rfr-pf2x-g4xf lists affected ranges: Maven org.geoserver:gs-main >=0 =0 <2.23.3) Commands are suggestions: review each one before running it.
Loading voting…