Skip to content

← Actionable
Medium, CVSS 4.2amended

OctoPrint Unverified Password Change via Access Control Settings

CVE-2024-23637GHSA-5626-pw9c-hmjr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (octoprint 1.10.0rc1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI octoprint

    Affected
    <= 1.9.3
    Fixed in
    1.10.0rc1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.2 · CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L
EPSS
  • CVE-2024-23637: 0.52% estimated exploitation activity in the next 30 days; percentile 44.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact OctoPrint versions up until and including 1.9.3 contain a vulnerability that allows malicious admins to change the password of other admin accounts, including their own, without having to repeat their password. An attacker who managed to hijack an admin account might use this to lock out actual admins from their OctoPrint instance. Patches The vulnerability will be patched in version 1.10.0. Workarounds OctoPrint administrators are strongly advised to thoroughly vet who has admin access to their installation. Credits This vulnerability was discovered and responsibly disclosed to OctoPrint by Timothy "TK" Ruppert.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-5626-pw9c-hmjr

  2. Revision 1 · created ·

    Published from osv record GHSA-5626-pw9c-hmjr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-23637

Advisory: OctoPrint Unverified Password Change via Access Control Settings
IDs: CVE-2024-23637, GHSA-5626-pw9c-hmjr
Record: https://patchnext.com/advisories/cve-2024-23637 (revision 2, source checked 26 Oct 2026, 13:12 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: octoprint 1.10.0rc1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI octoprint: affected <= 1.9.3; fixed in 1.10.0rc1

## Suggested inspection (read-only)
- `python -m pip show octoprint`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on octoprint.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5626-pw9c-hmjr (OSV record GHSA-5626-pw9c-hmjr lists affected ranges: PyPI octoprint >=0 <1.10.0rc1 (fixed))
- Verified: https://github.com/advisories/GHSA-5626-pw9c-hmjr (GitHub-reviewed advisory GHSA-5626-pw9c-hmjr lists affected ranges: PyPI octoprint >=0 <=1.9.3)

Commands are suggestions: review each one before running it.

Loading voting…